802.11i/WPA2 Version 1 with WICD

Asked by Martin Huber on 2017-08-18

I would like to connect to a WLAN using WICD, but up to now, with everything I tried I get just the output "Bad Password". I tried all possible templates and did some tries writing an own template.

Version of WICD: 1.7.4

Here are the details of the WLAN:

IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1x

Further I've got a CA certificate of my institution as *.crt file.

What I get in wicd.log (using the debugging mode) are messages of the following kind

2017/08/18 07:48:52 :: ifconfig wlp2s0
2017/08/18 07:48:54 :: Connecting to wireless network schule
2017/08/18 07:48:54 :: iwconfig wlp2s0
2017/08/18 07:48:54 :: Executing /etc/network/if-down.d/avahi-autoipd with params
2017/08/18 07:48:54 :: /etc/network/if-down.d/avahi-autoipd returned 0
2017/08/18 07:48:54 :: Executing /etc/network/if-down.d/openvpn with params
2017/08/18 07:48:54 :: /etc/network/if-down.d/openvpn returned 0
2017/08/18 07:48:54 :: Executing /etc/network/if-down.d/resolvconf with params
2017/08/18 07:48:54 :: /etc/network/if-down.d/resolvconf returned 0
2017/08/18 07:48:54 :: Executing /etc/network/if-down.d/upstart with params
2017/08/18 07:48:54 :: /etc/network/if-down.d/upstart returned 0
2017/08/18 07:48:54 :: Executing /etc/network/if-down.d/wpasupplicant with params
2017/08/18 07:48:54 :: /etc/network/if-down.d/wpasupplicant returned 0
2017/08/18 07:48:54 :: /sbin/dhclient -v -r wlp2s0
2017/08/18 07:48:54 :: ifconfig wlp2s0 0.0.0.0
2017/08/18 07:48:54 :: /sbin/ip route flush dev wlp2s0
2017/08/18 07:48:54 :: ['/sbin/resolvconf', '-d', 'wlp2s0.wicd']
2017/08/18 07:48:54 :: ifconfig wlp2s0 down
2017/08/18 07:48:54 :: ifconfig wlp2s0 up
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/avahi-daemon with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/avahi-daemon returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/wireless-tools with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/wireless-tools returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/wpasupplicant with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2017/08/18 07:48:55 :: wpa_cli -i wlp2s0 terminate
2017/08/18 07:48:55 :: Executing /etc/network/if-down.d/avahi-autoipd with params
2017/08/18 07:48:55 :: /etc/network/if-down.d/avahi-autoipd returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-down.d/openvpn with params
2017/08/18 07:48:55 :: /etc/network/if-down.d/openvpn returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-down.d/resolvconf with params
2017/08/18 07:48:55 :: /etc/network/if-down.d/resolvconf returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-down.d/upstart with params
2017/08/18 07:48:55 :: /etc/network/if-down.d/upstart returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-down.d/wpasupplicant with params
2017/08/18 07:48:55 :: /etc/network/if-down.d/wpasupplicant returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/avahi-daemon with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/avahi-daemon returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/wireless-tools with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/wireless-tools returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-post-down.d/wpasupplicant with params
2017/08/18 07:48:55 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-pre-up.d/ethtool with params
2017/08/18 07:48:55 :: /etc/network/if-pre-up.d/ethtool returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-pre-up.d/wireless-tools with params
2017/08/18 07:48:55 :: /etc/network/if-pre-up.d/wireless-tools returned 0
2017/08/18 07:48:55 :: Executing /etc/network/if-pre-up.d/wpasupplicant with params
2017/08/18 07:48:55 :: /etc/network/if-pre-up.d/wpasupplicant returned 0
2017/08/18 07:48:55 :: Putting interface down
2017/08/18 07:48:55 :: ifconfig wlp2s0 down
2017/08/18 07:48:55 :: Releasing DHCP leases...
2017/08/18 07:48:55 :: /sbin/dhclient -v -r wlp2s0
2017/08/18 07:48:55 :: Setting false IP...
2017/08/18 07:48:55 :: ifconfig wlp2s0 0.0.0.0
2017/08/18 07:48:55 :: Stopping wpa_supplicant
2017/08/18 07:48:55 :: wpa_cli -i wlp2s0 terminate
2017/08/18 07:48:55 :: Flushing the routing table...
2017/08/18 07:48:55 :: /sbin/ip route flush dev wlp2s0
2017/08/18 07:48:55 :: ['/sbin/resolvconf', '-d', 'wlp2s0.wicd']
2017/08/18 07:48:55 :: iwconfig wlp2s0 mode managed
2017/08/18 07:48:55 :: Putting interface up...
2017/08/18 07:48:55 :: ifconfig wlp2s0 up
2017/08/18 07:48:57 :: enctype is mytemplate
2017/08/18 07:48:57 :: Attempting to authenticate...
2017/08/18 07:48:57 :: ['wpa_supplicant', '-B', '-i', 'wlp2s0', '-c', '/var/lib/wicd/configurations/2401c7c0f690', '-Dwext']
2017/08/18 07:48:57 :: ['iwconfig', 'wlp2s0', 'essid', '--', 'schule']
2017/08/18 07:48:57 :: iwconfig wlp2s0 channel 11
2017/08/18 07:48:57 :: iwconfig wlp2s0 ap 24:01:C7:C0:F6:90
2017/08/18 07:48:57 :: WPA_CLI RESULT IS DISCONNECTED
2017/08/18 07:48:58 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:48:59 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:00 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:01 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:02 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:03 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:04 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:05 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:06 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:07 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:08 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:09 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:10 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:11 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:12 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:13 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:14 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:15 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:16 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:17 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:18 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:19 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:20 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:21 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:22 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:23 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:24 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:25 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:26 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:27 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:28 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:29 :: WPA_CLI RESULT IS SCANNING
2017/08/18 07:49:30 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:31 :: WPA_CLI RESULT IS ASSOCIATING
2017/08/18 07:49:32 :: wpa_supplicant authentication may have failed.
2017/08/18 07:49:32 :: connect result is failed
2017/08/18 07:49:32 :: exiting connection thread
2017/08/18 07:49:33 :: Sending connection attempt result bad_pass

Many thanks for any help!

Question information

Language:
English Edit question
Status:
Solved
For:
wicd Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Huber
Solved:
2017-08-24
Last query:
2017-08-24
Last reply:
Martin Huber (martin-huber) said : #1

After further hours of googling I have finally found the solution

https://bbs.archlinux.org/viewtopic.php?id=88366

So the working template looks as follows:

name = ...
author = ...
version = ...
require identity *Identity password *Password
protected password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="$_ESSID"
        key_mgmt=WPA-EAP
        identity="$_IDENTITY"
        password="$_PASSWORD"
}