WICD suddenly not working

Asked by Dora on 2015-04-21

I installed WICD about a week and a half ago, on a Dell Inspiron B130 (ca 2007) running Ubuntu with a Xubuntu desktop interface. I have a Broadcom wireless mini-PC card. I had the wireless working, and connecting more or less consistently to wifi on the bus. It was much easier with WICD. Now it can't connect on the bus and can't connect wirelessly at home either.

Sometimes it is necessary to tell it the name of the router before it will find it, but that is not working. always it is necessary to tell the wireless driver to run, but that isn't working. For some reason it was preferring to use the wired adapter though I've not used it in a week and a half; I disabled that and removed the idiotic default wired connection and it still doesn't work.

WICD seems to have simply shut down. That it can't find any wireless networks could be due to a number of problems. The wireless adapter is getting a loopback IP address. However, I also can't switch off Wi-Fi. Now, if it isn't "on" due to driver issues it shouldn't be showing on and impossible to shut off. Disconnect all does nothing. Refresh sometimes does nothing, and sometimes scans and tells me it found no wireless networks. My apartment is surrounded with wireless networks, not to mention my own wireless router three feet from the computer.

How do I get WICD to work?

Yours,
Dora

Question information

Language:
English Edit question
Status:
Solved
For:
wicd Edit question
Assignee:
No assignee Edit question
Solved by:
Dora
Solved:
2015-04-22
Last query:
2015-04-22
Last reply:
Dora (tiggernut24) said : #1

People are so fast to answer here, it's probably a good thing the problem turned out to be I had my driver names mixed up.