ubuntu update: wicd doesn't work anymore

Asked by Mike Sussman on 2008-02-11

I am running Ubuntu gutsy. I have been using wicd for about a month on my HP Pavilion dv9500 and it was working to manage both the wired and wireless (Intel 4965AGN) network. This morning (Feb. 11) I ran an update and noticed that wicd was updated from the repository. Now, when I bring up the wicd gui and attempt to connect to the wireless network, nothing happens. It does not report failure, it does not close the wired connection, it is as if I am not clicking on "connect".

I made a copy of gui.py and put -d in the first line. I am not a Python user, but I figured that might tell me something. I started it up in a KDE konsole window and then checked "Enable debug mode" in Preferences.
Then I shut it down and started it up again. The wired network remains active from the previous. I can see what appears to be an error message, but I do not understand enough to respond to it.

My home network is the one with ESSID 5026Belmont. It is protected with WPA 1/2. The place for the key in the gui is filled with black dots, so I presume the key survived the update. I do not get a message saying the connection failed, as I got when I was setting wicd up originally and had the wrong key.

Please advise me either (a) how to revert to the earlier version, (b) how to repair this installation, or (c) what further steps to take to diagnose the problem. Thank you.

Here is the output copied from the konsole:
root@ozhp:/tmp/testwicd# ./gui.py
attempting to connect daemon...
success
starting gui.py...
refreshing...
using global dns: 0
disabling ip
disabling dns
dns checkbox toggled False
global dns checkbox toggled False
changing profile...
Home Wired
disabling ip
disabling dns
dns checkbox toggled False
global dns checkbox toggled False
wired profiles found
Number of wireless networks detected: 2
using global dns: 0
ESSID : 5026Belmont
making a new network entry...
disabling ip
disabling dns
dns checkbox toggled False
global dns checkbox toggled False
0
found language key key
using global dns: 0
ESSID : KV9U7
making a new network entry...
disabling ip
disabling dns
dns checkbox toggled False
global dns checkbox toggled False
0
found language key key
Traceback (most recent call last):
  File "./gui.py", line 1234, in connect
    wired.SetWirelessProperty(networkid, "ip", '')
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 135, in __call__
    **keywords)
  File "/var/lib/python-support/python2.5/dbus/connection.py", line 603, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.dbus.exceptions.UnknownMethodException: Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/dbus/service.py", line 625, in _message_cb
    (candidate_method, parent_method) = _method_lookup(self, method_name, interface_name)
  File "/var/lib/python-support/python2.5/dbus/service.py", line 231, in _method_lookup
    raise UnknownMethodException('%s is not a valid method of interface %s' % (method_name, dbus_interface))
UnknownMethodException: Unknown method: SetWirelessProperty is not a valid method of interface org.wicd.daemon.wired

Question information

Language:
English Edit question
Status:
Invalid
For:
wicd Edit question
Assignee:
No assignee Edit question
Solved by:
David Paleino
Solved:
2012-02-05
Last query:
2008-02-11
Last reply:
2012-02-05
Adam Blackburn (adamblackburn) said : #1

Looks like a typo in gui.py.

I'm fixing now; an update should be on the repository very soon.

Adam Blackburn (adamblackburn) said : #2

Update in repository, version 1.4.2.

Mike Sussman (msussman) said : #3

Thanks Adam, that solved my question.

banebab (banebab) said : #4

Using Feisty and wicd shows the same behavior as above, with the same error report. Never made it to work on my laptop. Is there the same typo in Feisty repository?

Adam Blackburn (adamblackburn) said : #5

No, the updated fixed version should be in the repository.

Do this:
sudo apt-get update
sudo apt-get upgrade

and see if the problem is still there. Perhaps you do not have the latest version?

banebab (banebab) said : #6

Thanks Adam! It turned out that I had some screwed up repository address in my sources list....changed it to correct one...upgraded....and it works.....finally. Sorry for that and thanks again!

gerben (gerben-rotman) said : #7

Can someone please explain how to get the fixed version, using another computer?

I cannot connect to the internet with my Ubuntu Linux laptop since this wicd update, so things like "sudo apt-get update" won't work.

thanks

Adam Blackburn (adamblackburn) said : #8

garben, download http://apt.wicd.net/pool/gutsy/extras/wicd_1.4.2-1-all.deb and install it on your laptop. For instance, use a USB flash disk to move it from one computer to another and then double click the file to install.

gerben (gerben-rotman) said : #9

Great, thanks a lot

Since the update I lost my connection without reason

David Paleino (dpaleino) said : #11

Invalidating old bug-report-like question.

Mike Sussman (msussman) said : #12

   http://rathdangan.com/wy/gvmccpgkqgrlaqij8vx29m5n?iysrywctj0w5b6h708kamfmyer17jw8mzro !!!

   MYRON SUSSMAN 2/8/2013 1:38:49 AM

   http://mail.yahoo.com
   %.arzwq678cx28spzy4nl