WEP encryption

Asked by yoshi86 on 2013-01-29

Arch linux - WEP encryption. In this bzr-wicd version (1.7.2.4) in WEP (HEX [0-9/A-F]) I have TWO input password fields. Not ONE as it was in previous wicd wersions.
These TWO are: KEY and KEY INDEX. I tried to put my password in these input filelds in every possible combination - failed, output bad password. I tried other WEP enc options as well (even if previous succesful option was WEP (HEX [0-9/A-F])) i tried WEP (PASSPHRASE) and WEP (SHARED/RESTRICTED) - failed as bad.

I'm sentenced to:
[code]iwconfig [interface] essid "XXXXXXXXXX" key ?????????? rate 48M[/code]
sleep few seconds and
[code]dhcpcd [interface][/code]
above reach to success

Should add that i need force Bitrate value connection rate48. My wicd-bzr have combobox "Wireless bitrate" but the only possible option is "auto".

My iwlist scan:
[code]
wlp7s0 Scan completed :
          Cell 01 - Address: XX:XX:XX:XX:XX:XX
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=67/70 Signal level=-43 dBm
                    Encryption key:on
                    ESSID:"XXXXXXXXXX"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s
                    Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000047c94e96ba
                    Extra: Last beacon: 54ms ago
                    IE: Unknown: 000A6D006764616C656E6B61
                    IE: Unknown: 0108828400960C183048
                    IE: Unknown: 030102
                    IE: Unknown: 2A0100
                    IE: Unknown: 32041224606C
[/code]

Question information

Language:
English Edit question
Status:
Solved
For:
wicd Edit question
Assignee:
No assignee Edit question
Solved by:
David Paleino
Solved:
2013-01-29
Last query:
2013-01-29
Last reply:
2013-01-29
Best David Paleino (dpaleino) said : #1

Simply, just put 0 (or 1) as key index, and your password in "key".

The bitrate choice in the GUI is based on the output of "iwlist wlan0 rate"; if it's only "auto" then probably the output doesn't show good options.

Kindly,
David

yoshi86 (yoshibz) said : #2

Thanks David Paleino, that solved my question.