error when changing settings in wicd-gtk. wicd-daemmon.py

Asked by Simen Andresen on 2012-12-08

Hi!
I tried to update wicd (to 1.7.2.4) on my laptop running Linux Mint. I first struggeled some with an error in the installing (due to ast.po), but finally got it installed with no errors. Now the problem is that I can't seem to be able to configure wicd from gtk (or curses for that matter). I keep on getting the error:

Traceback (most recent call last):
  File "/usr/share/wicd/gtk/netentry.py", line 945, in update_autoconnect
    noneToString(self.chkbox_autoconnect.
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1067, in SetWirelessProperty
    prop = misc.sanitize_config(prop)
  File "/usr/local/lib/python2.7/dist-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)

On some forums I read that some fixed this error by changing

       prop = misc.sanitize_config(prop)
to
       prop = misc.sanitize_config(str(prop))

But this had no effect for me. Any help would be much appriciated:)

Question information

Language:
English Edit question
Status:
Solved
For:
wicd Edit question
Assignee:
David Paleino Edit question
Solved by:
David Paleino
Solved:
2012-12-09
Last query:
2012-12-09
Last reply:
2012-12-08
Best David Paleino (dpaleino) said : #1

Please have a look at the bug I linked.

It's a known issue, and an -- I admit -- annoying bug. I thought I would've released 1.7.3 quickly, but that has been delayed to get more and more fixes in (see https://launchpad.net/wicd/+milestone/1.7.3).

Please have a look at commit 770:

  http://bazaar.launchpad.net/~wicd-devel/wicd/experimental/revision/770

it should fix your problem.

Sorry for the inconvenience,
David

Simen Andresen (simena86) said : #2

Thank you for quick reply! This solved the problem, but now I have a new one:

After i removed network-manager i dont seem to connect through urls in a browser. I get to connect to my router, and all looks nice except from that. Also it seems like I can ping ip adresses. So i guess theres something wrong with the DNS ? Have used quite some hours googling the problem , but didnt find any solutions that fixed it.

Thanks in advance,
Simen Andresen

Simen Andresen (simena86) said : #3

After switching to dhcp in the settings and rebooting it finally worked (along with deleting /etc/resolv.conf, but not sure if that was the thing that fixed the problem)

thanks anyways
Simen

Simen Andresen (simena86) said : #4

Thanks David Paleino, that solved my question.