setting password crash

Asked by Nicanor Arancibia on 2012-09-17

When i try to set the password, after i click "Accept", nothin happens, i can close the window manually, but it kinda "freeze" there, but i am still able to interact with the window

using Ubuntu 12.04 64bits

Question information

Language:
English Edit question
Status:
Solved
For:
wicd Edit question
Assignee:
No assignee Edit question
Solved by:
David Paleino
Solved:
2012-09-21
Last query:
2012-09-21
Last reply:
2012-09-18
PCManiac (pcmaniacpt) said : #1

You should consider posting the version of wicd you are running there. and perhaps to update to the latest version.

And you should try this:
1- close wicd-client and terminate any running instance of it
2- open a terminal and write wicd-client
3- set the "password" and, once it freezes, check in the terminal if it gives you any messaged or error.

If there is a message/erro, post it here to be easier to help you.
If not, consider turning on the debug and try the same, this time, showing here the wicd log.

Nicanor Arancibia (nikanor-95) said : #2

the version is 1.7.2.3

The terminal shows

--------------------------------------------------------------------------------------------------------------------------------
setting encryption info...
Traceback (most recent call last):
  File "/usr/share/wicd/gtk/gui.py", line 666, in edit_advanced
    if self.run_settings_dialog(dialog, ttype, networkid, networkentry):
  File "/usr/share/wicd/gtk/gui.py", line 679, in run_settings_dialog
    if self.save_settings(nettype, networkid, networkentry):
  File "/usr/share/wicd/gtk/gui.py", line 644, in save_settings
    if not networkentry.save_wireless_settings(networkid):
  File "/usr/share/wicd/gtk/netentry.py", line 940, in save_wireless_settings
    return self.advanced_dialog.save_settings(networkid)
  File "/usr/share/wicd/gtk/netentry.py", line 591, in save_settings
    encrypt_methods[self.combo_encryption.get_active()]['type'])
  File "/usr/share/wicd/gtk/netentry.py", line 532, in set_net_prop
    wireless.SetWirelessProperty(self.networkID, option, value)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1067, in SetWirelessProperty
    prop = misc.sanitize_config(prop)
  File "/usr/local/lib/python2.7/dist-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)

--------------------------------------------------------------------------------------------------------------------------------------------------------

Best David Paleino (dpaleino) said : #3

This is a known bug, which is already fixed in the yet-to-be-released version of wicd.

Please see the linked bugreport.

Kindly,
David

Nicanor Arancibia (nikanor-95) said : #4

Thanks!!

have a nice day!

Nicanor Arancibia (nikanor-95) said : #5

Thanks David Paleino, that solved my question.