Whyteboard: Simple whiteboard and PDF annotator

will not start on mac os X 10.6.2

Asked by Peter McMahan on 2010-01-10

Hi,
I'm unable to start whyteboard on my Macbook Pro (Mac OS X 10.6.2).
Simply running the command "./whyteboard.py" gives the following error:

Traceback (most recent call last):
  File "./whyteboard.py", line 53, in <module>
    import wx
  File "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/__init__.py", line 45, in <module>
  File "/var/tmp/wxWidgets/wxWidgets-13~231/2.6/DSTROOT/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core.py", line 4, in <module>
ImportError: /System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core_.so: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)

However running the command "python whyteboard.py" gives:

Traceback (most recent call last):
  File "whyteboard.py", line 56, in <module>
    from tools import (Image, Text, Line, Note, Select, OverlayShape, Media, Polygon,
  File "/Users/mcmahanp/Downloads/whyteboard-0.39.35/tools.py", line 34, in <module>
    from dialogs import TextInput
  File "/Users/mcmahanp/Downloads/whyteboard-0.39.35/dialogs.py", line 918, in <module>
    listmix.ListRowHighlighter):
AttributeError: 'module' object has no attribute 'ListRowHighlighter'

my wx.__version__ is 2.8.7.1, which I think is pretty recent. The python version is 2.5.4 (from the Enthought Python Distribution)
Any help would be very much appreciated.
Thanks,
Peter

Question information

Language:
English Edit question
Status:
Solved
For:
Whyteboard Edit question
Assignee:
No assignee Edit question
Solved by:
Peter McMahan
Solved:
2010-01-10
Last query:
2010-01-10
Last reply:
2010-01-10
Steven Sproat (sproaty) said : #1

Hi,

please see the README.txt file:

* Python - 2.5.4 or 2.6.4 (untested on other major versions; should work on 2.4)
* wxPython - latest version is -always- recommended (currently 2.8.10.1).
    ---- WXPYTHON 2.8.9.0 NEEDED AT MINIMUM

looking here, http://www.wxpython.org/recentchanges.php

you can see that 2.8.7.1 was released at the end of November 2007, so it is not a recent version. Upgrading to the latest wx should fix this problem.

also, you should run gui.py, not whyteboard.py. Are you using 0.39.35?

Thanks for the interest in the program, any feedback on how it runs on Mac would be appreciated, as I do not have a Mac available to even try the program (or to see if any mac-specific bugs/crashes exist etc)

regatds,
Steven

Steven Sproat (sproaty) said : #2

(by the way, is this the wx version that the Mac came with, pre-installed?) I recall the developer of wxPython mention how it's included with Macs, but is not kept up to date.

Peter McMahan (mcmahan) said : #3

Thanks,
the 'gui.py' (that i somehow missed) was the other tripping block. I upgraded my python version and my wx version, and running gui.py now works. I was using the python 2.5.4 version (old) of the Enthought Python Distribution: http://www.enthought.com/products/epd.php that comes with wx.
so far so good with the program working, too. thanks!

Steven Sproat (sproaty) said : #4

running whyteboard.py should work, but it's been broken for a few releases, now, so running gui.py is the way to start it.

Glad to hear your problem's fixed, and that it's running well! (btw any version, 2.4, 2.5, 2.6 *should* be able to run the program - although I haven't tried 2.4)
cheers for the interest in the program :)