error compiling basic example

Asked by mfmustamin

Dear Whizard team,

I just follow the instruction in the recent manual on installation. When I try to compile the hello.sin, everything is fine. However, as I try to do the same with ee.sin, I got the following error

| WHIZARD 3.0.0_beta
| Reading model file '/usr/local/share/whizard/models/SM.mdl'
| Preloaded model: SM
| Process library 'default_lib': initialized
| Preloaded library: default_lib
| Reading model file '/usr/local/share/whizard/models/SM_hadrons.mdl'
| Reading commands from file 'ee.sin'
| Process library 'default_lib': recorded process 'ee'
sqrts = 3.600000000000E+02
n_events = 10
| Starting simulation for process 'ee'
| Simulate: process 'ee' needs integration
| Integrate: current process library needs compilation
| Process library 'default_lib': compiling ...
| Process library 'default_lib': writing makefile
| Process library 'default_lib': removing old files
  RM default_lib.lo default_lib_driver.mod opr_ee_i1.mod ee_i1.lo
  RM ee_i1.f90
| Process library 'default_lib': writing driver
| Process library 'default_lib': creating source code
  RM ee_i1.f90,.mod,.lo
  OMEGA ee_i1.f90
[1/1] e- e+ -> mu- mu+ ... allowed. [time: 0.38 secs, total: 0.38 secs, remaining: 0.00 secs]
all processes done. [total time: 0.38 secs]
SUMMARY: 6 fusions, 2 propagators, 2 diagrams
SUMMARY: 4 vertices
| Process library 'default_lib': compiling sources
f951: Warning: Nonexistent include directory ‘NONE/lib/mod/whizard’ [-Wmissing-include-dirs]
f951: Warning: Nonexistent include directory ‘NONE/lib/mod/omega’ [-Wmissing-include-dirs]
f951: Warning: Nonexistent include directory ‘NONE/lib/mod/models’ [-Wmissing-include-dirs]

   use kinds
Fatal Error: Can't open module file ‘kinds.mod’ for reading at (1): No such file or directory
compilation terminated.
default_lib.makefile:60: recipe for target 'ee_i1.lo' failed
make: *** [ee_i1.lo] Error 1
| command: make compile -j1 -f default_lib.makefile
| Return code = 512
*** FATAL ERROR: System command returned with nonzero status code
WHIZARD run aborted.

It seems like there is a problem with fortran cimpiler. I have gfortran, gfortran-5, and gfortran-7 installed on my Ubuntu 18.04. Can you help me with this problem?

Best regards.

Question information

English Edit question
WHIZARD Edit question
Juergen Reuter Edit question
Solved by:
Juergen Reuter
Last query:
Last reply:
Revision history for this message
Best Juergen Reuter (j.r.reuter) said :

Dear mfmustamin,
thanks for your report. This is indeed a bug that slipped into the code when we added our new API to call Whizard as a library from external programs. Until the bug is fixed, please configure Whizard with --prefix=/usr/local (even if this is the default). That should work.

Revision history for this message
mfmustamin (mfmustamin) said :

Thanks Juergen Reuter, that solved my question.