Installtion in Fedora31 (QubesOS)

Asked by Tobias Striegl on 2020-06-08

Since it took me a while to install whizard-2.8.2 on Feodra-31 I share this information here: Maybe it is useful to someone.

I have done this installation in a virtual in machine in QubesOs so it might be possible that one (or even all?) steps refer to Fedora from QubesOs

repositories only. Nevertheless the errors occurring during the installation seem to happen in other installation processes in Fedora too.

The following I did twice in in a fresh VM and in my working VM later:

Starting with a fresh Fedroa-31:

>> sudo dnf install ocaml gcc-g++ g-fortran

>> sudo dnf group install "Development Tools"

During "make" the error appeared:

"Error cannot read spec title: /usr/rpm/redhat/redhat-hardend-cc1"

For fixing:

>> sudo dnf install redhat-rpm-config

Next error is:

"Error: rpc/types.h No such file or directory <rpc/types>"

For fixing:

>> sudo dnf install libtir-pc-devel

and run configure before with the options

>>configure --prefix=/yourpath/ --GFLAGS="-I/usr/include/tirpc" --GXXFLAGS="-I/usr/include/tirpc"

With this done the installation can be done.

Question information

Language:
English Edit question
Status:
Solved
For:
WHIZARD Edit question
Assignee:
Juergen Reuter Edit question
Solved by:
Juergen Reuter
Solved:
2020-06-08
Last query:
2020-06-08
Last reply:
2020-06-08
Best Juergen Reuter (j.r.reuter) said : #1

Thanks for the information. This is unfortunately the dependence of the system for the old StdHep event format. There are some workarounds for this problem already in the configure setup. But this is a new one. We should think about putting this in the manual and the wiki.

Juergen Reuter (j.r.reuter) said : #2

There is the workaround already included.

Tobias Striegl (stto) said : #3

Thanks Juergen Reuter, that solved my question.