Error during installation of Whizard alpha v2.8.3

Asked by Natasa Vukasinovic on 2019-12-05

Dear Whizard authors,

I am trying to install alpha version of Whizard 2.8.3 that Jürgen produced, because resonance histories didn't work with UFO models in Whizard 2.8.2.
Before installation I sourced environment ( script in attachment), run configure, then make. Compilation stops at vamp directory:

make[1]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp'
Making all in src
make[2]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp/src'
Makefile:994: Makefile.depend: No such file or directory
R'[[divisions.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/divisions.nw | divisions.f90
/bin/sh: divisions.f90: command not found
/bin/sh: R[[divisions.f90]]: command not found
make[2]: [divisions.f90] Error 127 (ignored)
R'[[vamp.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/vamp.nw | vamp.f90
/bin/sh: R[[vamp.f90]]: command not found
/bin/sh: vamp.f90: command not found
make[2]: [vamp.f90] Error 127 (ignored)
R'[[tao_random_numbers.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/tao_random_numbers.nw | tao_random_numbers.f90
/bin/sh: R[[tao_random_numbers.f90]]: command not found
/bin/sh: tao_random_numbers.f90: command not found
make[2]: [tao_random_numbers.f90] Error 127 (ignored)
R'[[vamp_stat.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/vamp_stat.nw | vamp_stat.f90
/bin/sh: R[[vamp_stat.f90]]: command not found
/bin/sh: vamp_stat.f90: command not found
make[2]: [vamp_stat.f90] Error 127 (ignored)
R'[[linalg.f90]]' ../../../vamp/src/prelude.nw ../../../vamp/src/linalg.nw | linalg.f90
/bin/sh: R[[linalg.f90]]: command not found
/bin/sh: linalg.f90: command not found
make[2]: [linalg.f90] Error 127 (ignored)
for src in divisions.f90 vamp.f90 ../../../vamp/src/exceptions.f90 tao_random_numbers.f90 ../../../vamp/src/tao52_random_numbers.f90 ../../../vamp/src/specfun.f90 vamp_stat.f90 ../../../vamp/src/histograms.f90 ../../../vamp/src/utils.f90 linalg.f90 ../../../vamp/src/products.f90; do \
   module="`basename $src | sed 's/\.f[90][0358]//'`"; \
   grep '^ *use ' $src \
     | grep -v '!NODEP!' \
     | sed -e 's/^ *use */'$module'.lo: /' \
           -e 's/, *only:.*//' \
           -e 's/, *&//' \
           -e 's/, *.*=>.*//' \
           -e 's/ *$/.lo/' \
     -e 's/iso_fortran_env\.lo//' ; \
 done > Makefile.depend
grep: divisions.f90: No such file or directory
grep: vamp.f90: No such file or directory
grep: tao_random_numbers.f90: No such file or directory
grep: vamp_stat.f90: No such file or directory
grep: linalg.f90: No such file or directory
make[2]: Leaving directory `/opt/whizard/whizard-2.8.3/build/vamp/src'
make[2]: Entering directory `/opt/whizard/whizard-2.8.3/build/vamp/src'

This loop constantly repeats.
I run make clean, but that doesn't help.

What do you suggest how to resolve this?

Question information

English Edit question
WHIZARD Edit question
Juergen Reuter Edit question
Last query:
Last reply:
Juergen Reuter (j.r.reuter) said : #1

This was formerly a bug, but I took the liberty to turn it into a question.

Juergen Reuter (j.r.reuter) said : #2

As mentioned in the corresponding bug report, the checkout from HepForge svn or from our public git needs noweb to extract code and documentation. Only our nightly builts behave like official releases and work without noweb, because we processed them through noweb already.

Juergen Reuter (j.r.reuter) said : #3

I think this issue is solved.

Juergen Reuter (j.r.reuter) said : #4

Juergen Reuter suggests this article as an answer to your question:
FAQ #3205: “WHIZARD build fails: /bin/sh: divisions.f90: command not found”.

Juergen Reuter (j.r.reuter) said : #5

I created a new FAQ in order to cover this.