linux terminal server doesnt work

Asked by asdfjkloe on 2009-08-20

Everything is working fine at the server, as long as i use it as normal workstation. But i also want to use the workstation as linux terminal server (lstp), which is very usefull in school. and everything worked so far.
But when i try to boot the client via pxe after installing webcontentcontrol, it doesnt work anymore. without webcontentcontrol the client is starting. so: obviousely any firewall rule or something like this has to change, so that client get everything to start via pxe. but I dont know what. Any idea?

I think it would be very usefull, if webcontentcontrol works with lstp. Both is good for schools ..

Question information

Language:
English Edit question
Status:
Answered
For:
WebContentControl Edit question
Assignee:
No assignee Edit question
Last query:
2009-08-20
Last reply:
2009-09-26
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

KIAaze (zohn-joidberg) said : #2

need to answer it. :)

KIAaze (zohn-joidberg) said : #3

message above was justification for reopening this. ^^
Sorry for answering so late.

Yes, it's probably caused by the firewall.
You can either deactivate it through the GUI or by command-line.

GUI:
To deactivate it temporarily:
Click the "FireHol on/off" button

To deactivate it permanently:
Advanced settings->Services->Click "Firehol running at startup"

CLI:
To deactivate it temporarily:
sudo service firehol stop
sudo /etc/init.d/firehol stop

To deactivate it permanently:
sudo update-rc.d -f firehol remove
sudo /usr/share/webcontentcontrol/scripts/service_setup.sh firehol off

To keep firehol running, but allow PXE: cf http://firehol.sourceforge.net/
I don't know if it's possible however.

KIAaze (zohn-joidberg) said : #4

The commands I gave are equivalent, i.e.:

To deactivate it temporarily:
sudo service firehol stop
OR
sudo /etc/init.d/firehol stop

To deactivate it permanently:
sudo update-rc.d -f firehol remove
OR
sudo /usr/share/webcontentcontrol/scripts/service_setup.sh firehol off

Can you help with this problem?

Provide an answer of your own, or ask asdfjkloe for more information if necessary.

To post a message you must log in.