tc_banned contains no groups

Asked by chaim post on 2010-09-26

Web Content Control version 1.3.7
ubuntu 10.04

when I click the "apply all settings" button the terminal window says:

   "/usr/share/webcontentcontrol/scripts/tc_allowed does not contain any groups
    `/usr/share/webcontentcontrol/scripts/tc_banned' -> `/tmp/tmp.HpwtVv4op9'
     nlines=0
     ==============
     none==============
     /usr/share/webcontentcontrol/scripts/tc_banned does not contain any groups"

I have been having truoble accessing several websites including ubuntu forums, lifehacker, and gizmodo. I was wondering if this message could affect that or not? and if not is it a problem that I need to worry about?

thanks

Question information

Language:
English Edit question
Status:
Solved
For:
WebContentControl Edit question
Assignee:
No assignee Edit question
Solved by:
KIAaze
Solved:
2010-09-27
Last query:
2010-09-27
Last reply:
2010-09-27
Best KIAaze (zohn-joidberg) said : #1

No "tc_banned" and "tc_allowed" are related to program execution controls, i.e. they control to which groups a user belongs or not.

If you get an "access denied" page when you go on ubuntuforums, lifehacker or gizmodo, then it's normal blocking in action and you should check the dansguardian logs and the dansguardian configuration files to see what causes it.

If you just get a blank page, it's probably related to this issue:
https://launchpad.net/webcontentcontrol/+announcement/4830

It's a frustrating problem, but I think unless I start digging in the dansguardian source code myself, I'll be unable to fix it.

P.S.: Explanations about "tc_banned" and "tc_allowed":
Those files are filled using the "Program permissions" tab.
When applting the settings, the currently selected user will be added to all groups in "tc_allowed" and removed from all groups in "tc_banned".
That way you can control which programs a user is allowed to use by changing the ownership (chown) and permissions (chmod) of certain executables.
ex:
User added to group "alpha" and removed from group "beta".
"/usr/bin/foo" permissions: -rwxr-x--- 1 root alpha
"/usr/bin/bar" permissions: -rwxr-x--- 1 root beta
Now, the user will be able to use "foo", but not "bar".

chaim post (chaimpost) said : #2

Thanks KIAaze, that solved my question.