Problem with installing

Asked by Tiddens on 2010-05-26

We really need parental controls for our new TV PC product The Wave (at CatchTheWaveTV.com). I am getting the following error on installation:
waveuser@thewave:~/webcontentcontrol-1.3.2$ ./configure && make && sudo make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) mawk
checking for a BSD-compatible install... /usr/bin/install -c
configure: creating ./config.status
config.status: creating Makefile

WebContentControl has been configured with the following options:
                     prefix = /usr
                     bindir = /usr/bin
                     WCC_CONFIG = yes
                     WCC_PROXY = tinyproxy
-->webcontentcontrol_GUI/webcontentcontrol_GUI.gambas target called
-->all target called
WCC_CONFIG=yes
WCC_PROXY=tinyproxy
cd ./webcontentcontrol_GUI && gbc2 && gba2
/bin/bash: gbc2: command not found
make: *** [all] Error 127

Question information

Language:
English Edit question
Status:
Solved
For:
WebContentControl Edit question
Assignee:
No assignee Edit question
Solved by:
Tiddens
Solved:
2010-05-26
Last query:
2010-05-26
Last reply:
2010-05-26
KIAaze (zohn-joidberg) said : #1

If you install from source, you need to install the dependencies first:
sudo apt-get install gambas2-runtime gambas2-gb-qt gambas2-gb-form
gambas2-gb-form-dialog gambas2-gb-qt-kde gambas2-gb-qt-kde-html
sudo apt-get install dansguardian tinyproxy firehol

cf http://ubuntuforums.org/showthread.php?t=843510

I don't have much time at the moment for support.
Since you plan to use the parental controls in a commercial product,
you may be interested in SmoothWall:
http://dansguardian.org/?page=smoothwall
http://www.smoothwall.net/

Tiddens (tiddens) said : #2

Thanks! I would suggest going to https://addons.mozilla.org/ , search for "parental", and installing either ProCon Latte or Foxfilter.