'apps.indicators.weather' does not contain a key named 'heat-estimate'

Asked by gcclinux on 2013-05-31

I have now completely removed the apps and re-installed it twice and still no luck, please advise.

$ sudo apt-get install indicator-weather
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  python-pywapi
The following NEW packages will be installed
  indicator-weather python-pywapi
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 133 kB of archives.
After this operation, 992 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://gb.archive.ubuntu.com/ubuntu/ quantal/universe python-pywapi all 0.2.2-1 [9,686 B]
Get:2 http://gb.archive.ubuntu.com/ubuntu/ quantal-updates/universe indicator-weather all 12.07.30-0ubuntu1.1 [124 kB]

ERROR:

$ indicator-weather

(indicator-weather:16736): GLib-GIO-ERROR **: Settings schema 'apps.indicators.weather' does not contain a key named 'heat-estimate'
Trace/breakpoint trap (core dumped)

SOME DETAILS:

$ gsettings list-recursively apps.indicators.weather
apps.indicators.weather condition-fields '["heat-index", "humidity", "wind", "sun"]'
apps.indicators.weather filter-fields true
apps.indicators.weather global-notifications false
apps.indicators.weather indicator-display 0
apps.indicators.weather locations '{}'
apps.indicators.weather metric-system 'S'
apps.indicators.weather notifications 'N'
apps.indicators.weather placechosen 0
apps.indicators.weather places '[]'
apps.indicators.weather refresh-rate 15
apps.indicators.weather show-forecast true
apps.indicators.weather show-locations false
apps.indicators.weather weather '{}'
apps.indicators.weather weather-source 'Y'
apps.indicators.weather wind-unit 'mph'

SYSTEM:

$ sudo lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

Question information

Language:
English Edit question
Status:
Answered
For:
Weather Indicator Edit question
Assignee:
No assignee Edit question
Last query:
2013-05-31
Last reply:
2013-06-06
Joshua Tasker (jtasker) said : #1

Please update to the latest release (13.05.27), which you can get here:
https://launchpad.net/weather-indicator/2.0/13.05.27

Or, you can use the Weather-Indicator-Team PPA here:
https://launchpad.net/~weather-indicator-team/+archive/ppa

Note that it requires a newer version of pywapi, which you can get here:
https://launchpad.net/python-weather-api/trunk/0.3.3

Or from the pywapi PPA here:
https://launchpad.net/~pywapi-devel/+archive/ppa

Can you help with this problem?

Provide an answer of your own, or ask gcclinux for more information if necessary.

To post a message you must log in.