Enabled unsupported setting now black screen

Asked by Albert Kramps on 2016-12-10

Hello all I ran in to a little problem. I got Wargus 2.4.1 working in RetroPie and I desided ti play with some of the settings and not thinking i enabled OpenGL. Now my game will not start. When I go to start the game now all i get is a black screen and crash back to the game selection screen.

This is the error i get in the log. Parameters:
Executing: /opt/retropie/emulators/stratagus/stratagus -F -d "/home/pi/RetroPie/roms/stratagus/wargus.data"
Couldn't set 1024x768x32 video mode: OpenGL not available

I tried everything even deleting everything i could find connected to Wargus and Stratagus and reinstalling it all but i'm still getting the same error.

Anybody know where the settings file/info are kept in Linux/RetroPie?

Question information

Language:
English Edit question
Status:
Solved
For:
Wargus Edit question
Assignee:
No assignee Edit question
Solved by:
timfelgentreff
Solved:
2016-12-10
Last query:
2016-12-10
Last reply:
2016-12-10

You have a $HOME/.stratagus directory with the settings. Delete that to
remove local settings.

Albert Kramps <email address hidden> schrieb am Sa., 10.
Dez. 2016, 15:47:

> New question #406616 on Wargus:
> https://answers.launchpad.net/wargus/+question/406616
>
> Hello all I ran in to a little problem. I got Wargus 2.4.1 working in
> RetroPie and I desided ti play with some of the settings and not thinking i
> enabled OpenGL. Now my game will not start. When I go to start the game now
> all i get is a black screen and crash back to the game selection screen.
>
> This is the error i get in the log. Parameters:
> Executing: /opt/retropie/emulators/stratagus/stratagus -F -d
> "/home/pi/RetroPie/roms/stratagus/wargus.data"
> Couldn't set 1024x768x32 video mode: OpenGL not available
>
> I tried everything even deleting everything i could find connected to
> Wargus and Stratagus and reinstalling it all but i'm still getting the same
> error.
>
> Anybody know where the settings file/info are kept in Linux/RetroPie?
>
> --
> You received this question notification because your team Stratagus is
> an answer contact for Wargus.
>

Albert Kramps (cptklink) said : #2

Thanks timfelgentreff, that solved my question.