Not work translation of "PO" files

Asked by Skawer on 2013-05-23

preferences.lua
wc2.preferences.StratagusTranslation = "ru_RU.po"
wc2.preferences.GameTranslation = "ru_RU.po"

ru_RU.po
msgid ""
msgstr ""

msgid "~!Single Player Game"
msgstr "testtesttest"

d'nt work =(

Question information

Language:
English Edit question
Status:
Answered
For:
Wargus Edit question
Assignee:
No assignee Edit question
Last query:
2013-05-23
Last reply:
2014-05-24

This question was originally filed as bug #1183343.

Skawer (skawer) said : #1

preferences.lua
wc2.preferences.StratagusTranslation = "ru_RU.po"
wc2.preferences.GameTranslation = "ru_RU.po"

ru_RU.po
msgid ""
msgstr ""

msgid "~!Single Player Game"
msgstr "testtesttest"

d'nt work =(

cybermind (iddqd-mail) said : #2

You need to call function "_("string_to_translate")", which tells stratagus, that this string should be translated.
So, just replace your "~!Single Player Game" string with _("~!Single Player Game") (i think this string is located in guichan.lua)
As a reference, you can download Doom Wars, which is translated to russian: http://forums.stratagus.com/viewforum.php?f=24

Can you help with this problem?

Provide an answer of your own, or ask Skawer for more information if necessary.

To post a message you must log in.