cinematics

Asked by yfm on 2012-01-15

How do i make wargus run cinematics when they are supposed to be in warcraft 2?

Question information

Language:
English Edit question
Status:
Answered
For:
Wargus Edit question
Assignee:
Pali Edit question
Last query:
2012-01-15
Last reply:
2012-01-15
Pali (pali) said : #1

Cinematics are working fine in Wargus. You need to compile Stratagus with theroa library.

Travis (dinky-dye-aussie) said : #2

I've compiled it using the thora library. it plays the audio, but no visuals show, then it just errors out. When I debug it says that line 144 :

    SDL_DisplayYUVOverlay(yuv_overlay, rect);

Stuffed up. I've tried compiling it with a newer version of theora and it hasn't worked either. I reckon it's an MSVC compiler problem.

Travis (dinky-dye-aussie) said : #3

sorry, I meant to say line 144 of movie.cpp

Joris Dauphin (joris-dauphin) said : #4

I'm not familiar with this code :-/

I have no problem when compiling with gcc (on windows)
and with visual, video is unreadable, but I have no crash.

I won't have time to investigate on this problem.

Travis (dinky-dye-aussie) said : #5

what version of theora are you using? I am just using the one that comes in the msvc-libs.zip file that I downloaded through the stratagus webpage.

Joris Dauphin (joris-dauphin) said : #6

The same, I use it too for vs.

Pali (pali) said : #7

I think you have this problem: https://bugs.launchpad.net/stratagus/+bug/685103
Seems nothing related with Stratagus or Wargus. No idea how to fix it.

If you want, I can upload that SDL binaries compiled by i586-mingw32msvc-gcc

Travis (dinky-dye-aussie) said : #8

please do pali, I'll try anything at this time to make the whole game run mint

Travis (dinky-dye-aussie) said : #9

The bug in that link is exactly what I am talking about. I also just test the game at 640x480 res, and you are right about the movies working at the resolution, and that when SDL has to stretch it, it chucks a tantrum and won't do it for anything resolution higher than 640x480...hmmmm interesting.

I'm going to try and compile with SDL 1.2.14 now to see what that does.

Travis (dinky-dye-aussie) said : #10

Well, the Videos work with version 1.2.14, and 1.2.13, but again, the palette is rainbow. I think it was the same with 1.2.15 as well...I'll try again when I get those library files off of you.

Pali (pali) said : #11

I wrote you mail via launchpad, but you did not answer them... Please contact me via email/launchpad and I will send you builded binaries.

Can you help with this problem?

Provide an answer of your own, or ask yfm for more information if necessary.

To post a message you must log in.