troubleshooting

Asked by b-o on 2011-12-29

I've installed stratagus 2.2.6 x86(64bit) and wargus 2.2.6 x86 64 bit on windows 7 (64 bit), but nothing ever happens when I click on the stratagus or wargus icons. There is no error message or anything.

Question information

Language:
English Edit question
Status:
Solved
For:
Wargus Edit question
Assignee:
Pali Edit question
Solved by:
b-o
Solved:
2011-12-29
Last query:
2011-12-29
Last reply:
2011-12-29
Pali (pali) said : #1

I do not have Windows 7 PC and I compiled both 32 and 64 bit versions on Linux with cross compilers.

Was installation process successfull?
Can you try to start wargus.exe from Installation dir?
Can you try to start Wargus from console?

Starting from console:
1. Start --> Run --> cmd.exe
2. Change to Stratagus directory: cd "C:\Program Files\Stratagus"
3. Run Stratagus with Wargus data: stratagus.exe -d "C:\Program Files\Wargus"
(change Statagus and Wargus directory to your)

In cmd console you can see message log. Can you share your console log?

b-o (chokofehler) said : #2

Those 3 steps were successful, and the game was running, I'm not sure why the icons don't work.

Nothing happens when I run "C:\Program Files\Wargus\wargus.exe" in the console

Pali (pali) said : #3

wargus.exe on Windows is looking for data in working directory. If shortcut icon (on desktop) has other working directory it does not work...

b-o (chokofehler) said : #4

When the Wargus icon has "C:\Program Files\Wargus" as the working directory, nothing happens. When it has "C:\Program Files\Stratagus" as the working directory it says that the wargus data was not extracted from the Warcraft 2 cd. The Wargus installer had already extracted the Warcraft 2 data from the cd into the "C:\Program Files\Wargus" directory.

I don't know why the wargus exe never does anything, but I am not worried about it anymore because I can bypass it by using the stratagus.exe instead.

I've made a new shortcut with this as the target: "C:\Program Files\Stratagus\stratagus.exe" -d "C:\Program Files\Wargus"
And this as the starting directory: "C:\Program Files\Stratagus"

My problem is solved, I'm not sure about the wargus.exe problem being solved though.

anormal (el-anormal) said : #5

I am having the same issue on Windows 7 (64 bit) and the workaround (running "C:\Program Files\Stratagus\stratagus.exe" -d "C:\Program Files\Wargus") successfully launch the game.

Pali (pali) said : #6

Bug #1020815 is fixed now and wargus.exe working again.