Preference issue on Windows 7

Asked by Daniel Hannum on 2011-02-23

Hi,

I just installed Stratagus and Wargus on Windows 7 and while the game works great, I can't save or load games. Also, I think it's supposed to let me pick, in campaign mode, from the missions I've finished, but it only shows 2. If I had to guess, it's failing to save data, perhaps it's not putting it in my home and trying to write to Program Files instead? (because I know Windows 7 blocks that) I did see a ".stratagus-2.2" under Program Files\Stratagus, which looked suspicious.

What I want is to be able to save/load (obviously) and hopefully tweak a config file someplace to make Wargus "think" that I have beaten all the campaigns so I can pick which mission I want from the menu.

I didn't see any log or anything to tell me what is wrong. Any help is appreciated.

Thanks
Dan

Question information

Language:
English Edit question
Status:
Solved
For:
Wargus Edit question
Assignee:
Pali Edit question
Solved by:
Pali
Solved:
2011-02-25
Last query:
2011-02-25
Last reply:
2011-02-24
Daniel Hannum (daniel-hannum) said : #1

I saw someone else mention running it in console to see the output:

Can't save to `game.sav'
error in error handling
error in error handling

I think it's probably trying to save data to a place it's not allowed to. Thanks in advance.

Pali (pali) said : #2

Stratagus save all data and config files to <install_dir>\Stratagus\.stratagus-<version>
Windows NSIS Installer create this directory and try to set permitions for writing.

If you have problems, with saving it is problem with permitions in your OS. So set full access for directory <install_dir\Stratagus\.stratagus-<version>

Daniel Hannum (daniel-hannum) said : #3

Thanks, I ended up just reinstalling it in my home directory and everything works fine now.

One other question. When I alt-tab out of Wargus, it still grabs the mouse and I end up with the mouse pointer stuck in the upper left of the screen. I can still alt-tab back and the game is fine, but it prevents me from jumping out of the game to Windows for a minute.

Is this a bug or do I have a setting wrong?

Best Pali (pali) said : #4

It is problem/bug in SDL (I saw this problem only on Windows). Report bug to SDL.

Daniel Hannum (daniel-hannum) said : #5

Thanks Pali, that solved my question.