Wallch does not respond to preference settings

Asked by James M. Blue

I set the preferences file in Wallch to autostart but it never autostarts, I have to open the gui an hit the start button for it to start changing the wallpaper. I used it for a week or so doing that and was ok with having to do it on every boot. Today I decided to try the auto enable the Live Earth and auto enable picture of the day features. But when I select either one and stop and start Wallch or reboot completely, the regular wallpapers start to change. Do I have to clear the wallpapers that I have selected for program to change to make the other features work? I certainly hope that's not true as it makes the program which works very well other than the two things I mention above troublesome and clumsey to use if one likes use all the features for diversity.

Question information

English Edit question
Wallch Edit question
No assignee Edit question
Solved by:
Alex Solanos
Last query:
Last reply:
Revision history for this message
Best Alex Solanos (hakermania) said :

Hello James, you seem to be using an old version of Wallch, because that's kind of an old bug you've encountered.

Please try to unistall Wallch and install the newest version from the PPA:

To install it through a terminal:

sudo add-apt-repository ppa:wallch/3+
sudo apt-get update && sudo apt-get install wallch

Revision history for this message
James M. Blue (miltblue-m) said :

I made sure that I had the latest version 3.0 installed and uninstalled it and reinstalled the software more than once but it never would auto-start or save any preferences other than the one listed under the general category in the .config file. I saw the references to the earlier bug so I was aware of it . If i had an idea of what the .config file entries should have looked like I would have entered them manually, but while searching for info on how or what format they should be in I discovered Variety and uninstalled Wallch. It work perfectly and offers more options. I'm going to close this problem but its real and not solved . Thanks for the quick response

Revision history for this message
Alex Solanos (hakermania) said :

Whatever it works best for you :)