What is the command line to place in the startup aplications to allow Wallch to start automatically

Asked by Alan Haan

I am trying to get Wallch to start-up automatically. I have the /usr/bin/wallch command in the command window, but it only brings up the program, and doesn't start it in background mode. I have tried to add -Start and /Start. but there is no reference in the help files. Please email me with the correct command line to edit what I have.... My email address is <email address hidden>

Question information

English Edit question
Wallch Edit question
No assignee Edit question
Solved by:
Alex Solanos
Last query:
Last reply:
Revision history for this message
Alex Solanos (hakermania) said :

Hello Alan! Why exactly don't you do this via the Preferences dialog of Wallch?

Who told you that you have to manually make it manually? Wallch has automatic functions for this. Also, I am not going to email you because there are maybe people here with the same problem with you and, if I email you they will still have the question in their mind, because they will not be able to see my answer.

Revision history for this message
Alan Haan (a-h-1060) said :

I have tried to use the Automatic function, but for some reason it will not place the command line in the field. I have removed the app and reinstalled it, with no luck or change. On start-up, I have the App coming up on the screen, where all I have to do is click start and it will perform as it is suppose to.

Revision history for this message
Best Alex Solanos (hakermania) said :

Well, that's not the normal behavior. Hm... Please do the following, first of all, go to your startup applications and *remove* anything you have done by hand. Then, open a terminal (with Ctrl+Alt+T) and type in:

    mkdir -p ~/.config/autostart/

Then, open Wallch and head to the Preferences Dialog, go to the 'Startup' section, select to 'Enable Startup Option', choose your option and hit on the 'Save' button on the bottom of the Preferences Dialog.

Close Wallch and restart your PC. Login to your account. Does it work?

Revision history for this message
Alan Haan (a-h-1060) said :

Thankyou very much. That did solve my problem. Question why the new directory? Was it missing?

Revision history for this message
Alex Solanos (hakermania) said :

You are probably using an old version of Wallch, because, even the current one at the Ubuntu Software Center (3.01), which is available to you if you run Ubuntu 12.04, has solved this bug.

This was a bug of the previous versions of Wallch, but it has been solved after the release of the 3rd version...