wallch doesn't run in xubuntu

Asked by Alfredo Villanueva

Wallch doesn't work in xubuntu 11.10
wallpapers no change.

Question information

English Edit question
Wallch Edit question
No assignee Edit question
Solved by:
Alex Solanos
Last query:
Last reply:
Revision history for this message
Alex Solanos (hakermania) said :

Hello Alfredo VIllanueva!

Wallch is designed to run in GNOME.
Although, what really makes it run in GNOME is a gsettings command that runs only in gnome.

It would be quite easy to add a dialog in the program that lets you choose your own command (maybe it will let you also choose between some popular Operating Systems so as not to have to search for the appropriate command all the time, if you don't run gnome).

I think it's a pretty cool idea, but as you understand, Wallch ir right now unable to change wallpapers in kubuntu!

Revision history for this message
Best Alex Solanos (hakermania) said :

Hello there!
I've released a testing PPA (quite stable though) with some new features, which also solves the problems you had.
You can find it here:

Specifically, current latest versions of this ppa are:

You can add this ppa, so as to receive updates from it as well, as following:
sudo add-apt-repository ppa:wallch/3+
sudo apt-get update && sudo apt-get install wallch

I repeat that these are testing versions of Wallch that fix some bugs and have some new features, but it is logical to have some bugs. Please, if you find any, report it at: https://bugs.launchpad.net/wallpaper-changer/+filebug

Thanks a lot!

Revision history for this message
Alfredo Villanueva (dakosta2) said :

Thanks alexsol, that solved my question.