When I try to install Vocal from the PPA I get an error about missing dependencies

Created by Nathan Dyer on on 2014-07-06
Keywords:
Last updated by:
Nathan Dyer on on 2014-07-06

Are you seeing this error when trying to install Vocal?:

The following packages have unmet dependencies:
 vocal : Depends: libgranite2 (>= 0.2.0) but it is not installable
         Depends: libgtk-3-0 (>= 3.11.5) but 3.10.8-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Vocal is designed for elementary OS Freya and later, which has newer versions of GTK and Granite. Both packages are needed at this time for it to work correctly.

To correct this error you will need to install them from the elementary OS Daily and Testing PPAs. Please know that these PPAs are unstable and could cause your system to become buggy or unusable. Make sure this is something you actually want to do before you do it.

When in doubt, wait for the stable release :)

If you want to go ahead and test Vocal you will need to add these two PPAs:

ppa:elementary-os/daily
ppa:elementary-os/testing

Be sure to update your software before trying to install Vocal again. If you have held broken packages you may also need to fix your software catalogue using the command 'sudo apt-get install -f'