VM

VM not prompting IMAP password on initial startup

Asked by Robert. D Houk on 2013-02-05

Hi. I'm trying (and mostly succeeding) to upgrade to vm 8.2.0b (emacs 24.2) from
vm 7.19 (emacs 20.3 -- yes, 20.3, I built that binary in 1996 and have been using it
for the past decade and a half!), Solaris 10 SPARC.

I've managed to figure out pretty much every issue but one: When I first fire up
vm (M-x vm), everything works (reads .vm; loads my inbox, etc.) except that vm
does not ask me for my IMAP password, rather it fails and beeps at me. If I then
issue a "g" command, it nicely asks for my password, successfully gloms onto my
IMAP server, downloads new email, and so on; everything works fine afterwards.

Here is the *Messages* output showing initial failure on fresh startup:

For information about GNU Emacs and the GNU system, type C-h C-a.
("/home/rhouk/emacs-VM/vm-8.2.0b-gnu23/lisp" "~/elisp" "/pkg/gnu/share/emacs/24.2/site-lisp" "/pkg/gnu/share/emacs/site-lisp" "/pkg/gnu/share/emacs/24.2/lisp" "/pkg/gnu/share/emacs/24.2/lisp/vc" "/pkg/gnu/share/emacs/24.2/lisp/url" "/pkg/gnu/share/emacs/24.2/lisp/textmodes" "/pkg/gnu/share/emacs/24.2/lisp/progmodes" "/pkg/gnu/share/emacs/24.2/lisp/play" "/pkg/gnu/share/emacs/24.2/lisp/org" "/pkg/gnu/share/emacs/24.2/lisp/nxml" ...)
("/home/rhouk/emacs-VM/vm-8.2.0b-gnu23/info" "/pkg/gnu/share/info/" "/usr/local/share/info/" "/usr/local/info/" "/usr/local/gnu/info/" "/usr/local/gnu/lib/info/" "/usr/local/gnu/lib/emacs/info/" "/usr/local/emacs/info/" "/usr/local/lib/info/" "/usr/local/lib/emacs/info/")
vm-autoloads
WARNING: Could not load feature bbdb.
WARNING: Related functions may not work correctly!
Adding vm-rfaddons-option `check-recipients'.
Adding vm-rfaddons-option `check-for-empty-subject'.
Adding vm-rfaddons-option `encode-headers'.
VM-RFADDONS: Options loaded.
Reading folder /home/rhouk/VMAIL... done
Reading attributes... done
Reordering messages... done
3619 messages, 3 new, 0 unread, 3001 deleted [2 times]
Checking for new mail for /home/rhouk/VMAIL...
vm-imap-make-session: Need password for <email address hidden>@stbeehive.oracle.com [Inbox] for movemail

Then when I type "g":

Checking for new mail...
Added to /home/rhouk/VMAIL
Got mail from <email address hidden>@stbeehive.oracle.com [Inbox].
3621 messages, 4 new, 0 unread, 3001 deleted [2 times]

and everything's fine after that.

A brief excerpt from my .vm file:

;; Reading behavior
(setq vm-auto-get-new-mail t) ; Read spool(s) on M-x vm
(setq vm-startup-with-summary nil) ; Don't startup with summary
(setq vm-preview-lines nil) ; No preview, just display whole msg
(setq vm-jump-to-unread-messages t) ; Jump to unread messages before new
(setq vm-jump-to-new-messages nil)
(setq-default vm-summary-show-threads nil) ; Don't thread msgs by default
(setq vm-skip-deleted-messages t) ; Skip over ("n", "p") deleted msgs
(setq vm-skip-read-messages nil) ; Do NOT skip over merely-read msgs
(setq vm-auto-next-message nil) ; Do not SPACE to next msg, only "n"
(setq vm-move-after-deleting t) ; Goto next message on delete
(setq vm-mail-check-interval nil) ; I'll manually check when I want to

I'll send you my whole .vm file if you want it; didn't want to include the whole thing here.

I've tentatively assumed that none of the rf-addons stuff (see *Messages* above)
could possibly impact initial IMAP read/startup, since the configured Makefiles don't
work for me on Solaris-10, I haven't yet tried to manually de-configure the vm-rfaddons.
I've also assumed this is a user configuration error, not a bug, since every other
problem I've encountered has been resolved in my .vm file.

TIA!

     -RDH (Robert D. Houk)

Question information

Language:
English Edit question
Status:
Answered
For:
VM Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-05
Last reply:
2013-02-24
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Uday Reddy (reddyuday) said : #2

Sorry, I missed this question earlier.

Uday Reddy (reddyuday) said : #3

This is indeed a problem with the version 8.2.0b, which will be fixed in the next release.

My recommended method for password management is to create encrypted password files. If you look for "password" in the concept index of the manual, you will find directions on how to set them up.

Can you help with this problem?

Provide an answer of your own, or ask Robert. D Houk for more information if necessary.

To post a message you must log in.