VM

">" is automatically inserted when there is a sentence starting "From" in email contents

Asked by BVP on 2012-09-04

Hello.

I'm still using VM 8.1.0. Somehow, whenever I receive an email (plain text) containing a sentence that begins with "From",
vm automatically inserts ">" symbol before this "From". Hence, that sentence becomes ">From ..." instead of "From ..."
My guess is that vm tries to distinguish the email contents and the sender of the email "From:" , but this creates some inconvenience because the email contents are altered. I am wondering whether there is any solution for this problem.

Sincerely,
BVP

Question information

Language:
English Edit question
Status:
Answered
For:
VM Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-21
Last reply:
2018-08-24
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Uday Reddy (reddyuday) said : #2

We don't know whether VM has put the ">" symbols or some other Unix or mail tool that preceded it. You haven't said what kind of mail delivery agent you are using.

Assuming VM is at fault, using MMDF format for mail folders avoids the From-stuffing problem. You can set vm-default-folder-type to 'mmdf to make all new VM folders to be MMDF. To convert the old folders, the simplest thing to do would be to save their messages in a newly created MMDF folder and then delete the old folders.

BVP (bvp) said : #3

Hi, Uday.
Thanks for your suggestion. Just in case, we are using postfix and procmail for mail delivery agent. Do you think that these insert ">" in front of "From" sentences?

Uday Reddy (reddyuday) said : #4

Yes, that is possible. The mbox format is ambiguous, and the ">" signs on lines beginning with "From" is a way of avoiding the ambiguity. So, any tool that processes mbox format folders must take care to put the requisite ">" signs into new messages to avoid ambiguity.

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Uday Reddy (reddyuday) said : #6

Setting the status to Answered.

Can you help with this problem?

Provide an answer of your own, or ask BVP for more information if necessary.

To post a message you must log in.