VM

Cursor not at beginning of mail message

Asked by Kyle on 2010-12-08

I just upgraded from an old 7.19 to 8.1.93a and to a new version of xemacs, 21.5. I'm uncertain what my previous xemacs version was. I'm noticing some different behavior when moving between messages. I've ruled out the vm version bump; I rolled back to 7.19 and the behavior persists. Here is the behavior I am seeing:

When I move to a message via the Presentation buffer (forward or previous), the cursor is being positioned mid-body of the mail message. I'd like to get the cursor positioned at the beginning of the mail message, at the beginning of the content.

When I move to message via the Summary buffer (again, either direction), the Presentation is updated with the appropriate message but the cursor in the Summary buffer does no move up or down.

I've reduced my ".vm" file to a minimum to be certain this isn't the root cause. How can I change cursor positioning when I view messages? Is there something in more recent versions of emacs or xemacs that causes this?

thanks,
Kyle

Follow up: ok, this does not appear to be a VM issue. I "downgraded" from xemacs-21.5-b29 to xemacs-21.4.22 and cursor positioning appears ok. I'm not investigating this further as it's working for me, but if details are required for debugging let me know what you need and I can investigate.

Question information

Language:
English Edit question
Status:
Answered
For:
VM Edit question
Assignee:
Julian Bradfield Edit question
Last query:
2010-12-08
Last reply:
2012-01-15
Whiteboard:
Don, can you check if this problem is still present and flag it up to the XEmacs team?
Uday Reddy (reddyuday) said : #1

Dear Kyle, Thanks for the update. We don't have enough people on the current development team that use XEmacs. But I will flag it up to our XEmacs package maintainer.

Cheers,
Uday

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Uday Reddy (reddyuday) said : #3

This is a problem with XEmacs rather than VM. We will keep it open till it is resolved by the XEmacs team.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Uday Reddy (reddyuday) said : #5

Pesky janitor that!

Julian Bradfield (jcb+vm) said : #6

There have been a number of issues with XEmacs 21.5, VM and window
configuration type stuff. It's one of the main reasons I stopped using
21.5.

I'll keep it in mind, and look at it if I'm desperate for work
avoidance at some point, but supporting beta XEmacs is not a priority
for me.

Julian Bradfield (jcb+vm) said : #7

Actually, I see there was a proposed solution to this on xemacs-beta
in 2007.

Try applying the following patch to VM:

2007-09-07 Mike Sperber <email address hidden>

 * tapestry.el (tapestry-set-window-map): Use
 `frame-reduce-to-one-window' instead of `delete-other-windows' to
 keep the point from moving inadvertently.

Index: tapestry.el
===================================================================
RCS file: /pack/xemacscvs/XEmacs/packages/xemacs-packages/vm/tapestry.el,v
retrieving revision 1.5
diff -u -r1.5 tapestry.el
--- tapestry.el 3 Sep 2003 00:43:45 -0000 1.5
+++ tapestry.el 7 Sep 2007 08:29:13 -0000
@@ -205,7 +205,11 @@
    root-window )
       (if (tapestry-windows-match-map map map-width map-height)
    (tapestry-first-window)
- (delete-other-windows)
+ (if (fboundp 'frame-reduce-to-one-window)
+ (frame-reduce-to-one-window (selected-frame))
+ ;; `delete-other-windows' may cause the window point to move
+ ;; as it tries to minimize redisplay
+ (delete-other-windows))
  (setq root-window (selected-window))
  (tapestry-apply-window-map map map-width map-height root-window)
  (setq tapestry-windows-changed t)

--=-=-=--

Can you help with this problem?

Provide an answer of your own, or ask Kyle for more information if necessary.

To post a message you must log in.