emacs-w3m configuration with latest VM and Emacs

Asked by Sridhar Boovaraghavan on 2010-09-10

I am running the latest emacs trunk from bzr.

I also have the latest VM code.

I am trying to make vm-w3m work.

My emacs-w3m (retrieved from CVS) configuration is:

(require 'w3m-ems)

I am told to load this file and the remaining magic will be taken care of.

When I do, I get the following error message:

load: Symbol's value as variable is void: w3m-cid-retrieve-function-alist


Question information

English Edit question
VM Edit question
No assignee Edit question
Solved by:
Sridhar Boovaraghavan
Last query:
Last reply:
Tim Cross (tcross) said : #1

There are a couple of things to check.

1. Make sure w3m works. The variable w3m-cid-retrieve-function-alist is defined in w3m.el. If VM is unable to find the files for w3m, this could explain the problem.

Run M-x w3m and check w3m is working within emacs

2. Did you remember to build vm with the w3m library? When you run configure for VM you need to include the --with-other-files as documented in the INSTALL file. For example, on my system, I run

./configure --with-other-dirs=/"usr/share/emacs/site-lisp/w3m;/usr/share/emacs/site-lisp/bbdb/lisp"

(note that I build with BOTH w3m and BBDB, hence the two dirs in my list)

Verify this by checking that the output from configure has something like

checking otherdirs... ("/usr/share/emacs/site-lisp/w3m" "/usr/share/emacs/site-lisp/bbdb/lisp")

Let us know if you have done all of the above and it still does not work.


Thanks for the answer and sorry for the delay in my response.

With the information that you provided, I traced it down to two issues.

Because of http://www.emacswiki.org/emacs/emacs-w3m#toc14, I had used (require 'w3m-ems) instead of (require 'w3m-load) in my w3m configuration. Maybe something has changed in more recent emacsen (original article was for emacs ~23), but that didn't work. Also because of this, I had changed the vm-w3m line that loaded w3m to w3m-ems.

When I went back to the standard, things work well now.

Only thing is a message in the *Messages* buffer:

Loading vm-w3m...
Image conversion failed (code `4')
Loading vm-w3m...done

Is this important?


Uday Reddy (reddyuday) said : #3

I too have seen the "Image conversion failed" message occasionally. But, as far as I could tell, nothing is going wrong.