Ampache version support

Asked by James McClure on 2010-12-11

What version(s) of Ampache does Viridian support? I am running the latest Ampache svn (I think, rev 2456), and I keep recieving "Authentication Failed" messages.

Question information

Language:
English Edit question
Status:
Solved
For:
Viridian Edit question
Assignee:
No assignee Edit question
Solved by:
James McClure
Solved:
2010-12-11
Last query:
2010-12-11
Last reply:
James McClure (mcclurej06) said : #1

Never mind. I figured out what the problem was.

It might be helpful to note in the README that an ACL entry is needed.

Thats what I get for tryin to work at 2:30 AM...

Dave Eddy (daveeddydotcom) said : #2

Hm i could have sworn i had that information in the READE somewhere.. that's strange.

I'm glad it works for you now, I know exactly what that 2:30am feeling is like :)

Authentication is actually one of my weak parts in this code. Right now it only tells you if authentication failed or was successful, in my next release i'm going to have it give the exact reason it failed (timed out, acl error, incorrect password, etc.)

James McClure (mcclurej06) said : #3

One that note, Python isn't my strongest language but if you are looking for coders I'd be happy to help.

Tomas 'tt' Krag (tt) said : #4

James,

I'm having that exact problem, but can't seem to get my ACL entry right. (and it isn't 2:30 a.m.)
Is there any way you could help me by telling me which ACL lines did the trick?

cheers

/Tomas

James McClure (mcclurej06) said : #5

Ya, I will take a look at it when I can. Might be a day though.

James McClure (mcclurej06) said : #6

I don't remember which lines are specific to Viridian. These are all my ACL entries.

DEFAULTv4 0.0.0.0 255.255.255.255 All All Web Interface Edit Delete
DEFAULTv4 0.0.0.0 255.255.255.255 All All Stream Access Edit Delete
DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Web Interface Edit Delete
DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Stream Access Edit Delete
My Network 192.168.1.0 192.168.1.255 All All API/RPC Edit Delete
My Network 192.168.1.0 192.168.1.255 All All Stream Access Edit Delete

Dave Eddy (daveeddydotcom) said : #7

I have two ACL's in place to stream music to Viridian, both are specific to the user from which i connect.

Stream Access 0.0.0.0 to 255.255.255.255 for 'username' at level 'read'
API/RPC access 0.0.0.0 to 255.255.255.255 for 'username' at level 'view'

James McClure (mcclurej06) said : #8

Yeah, now that I look at it, that corresponds with the last two in my list (except mine are set to 'all' and 'all'.

Tomas 'tt' Krag (tt) said : #9

I've tried to copy both of those models, but unfortunately I keep getting Authentication Failed. message.

I've been looking at log files, and the request gets through to Apache, but nothing shows up in the Ampache log files.
I'm out of ideas, but thanks for the help anyway.

Regards

/Tomas

Dave Eddy (daveeddydotcom) said : #10

what version of Viridian are you using? if you pull the newest from launchpad (bzr checkout lp:viridianplayer) it should give you a detailed explanation of why the authentication fails.

Tomas 'tt' Krag (tt) said : #11

OK, I did that, but the new error-message is:

"Error Authenticating

Unknown error, possibly an incorrect URL specified, or the server is not responding."

Since I can copy and paste the URL from Viridian to my browser, and get straight access to the server, the error message seems not to be correct, except it's probably me that's gone and missed something really obvious.

When I enter the URL in my browser, i.e. http://domain.dk/ampache it gets forwarded to http://domain.dk/ampache/login.php or /index.php respectively, and that shows the Ampache frontend just like i'd expect.

cheers

/Tomas

Dave Eddy (daveeddydotcom) said : #12

Hm you're URL looks good, i'm just wondering if this is a timeout issue. When you access your ampache web interface directly is it slow? or is it almost instant?

Tomas 'tt' Krag (tt) said : #13

Sorry about the late reply, I've been away from my Viridian computer for a while.

The ampache interface seems snappy enough and the 3 "[Error] Authentication Failed -- Retry = X" messages show up in ess tha 2 seconds total.

Tomas 'tt' Krag (tt) said : #14

Success! I ended up just removing all traces of ampache, including the database, and reinstalling it from the ubuntu repository. Now viridian seems to connect perfectly. Still no idea what caused the problem, but it seems to be gone now.

thnaks everyone for the help.