updating variety to latest version

Asked by Dale Holtz on 2018-01-24

having problems getting variety updated to 0.6.6 on all my systems. running ubuntu16.04 that is currewnt on all. 1 system is running 0.6.6 and the rest are running 0.6.4 or 0.6.2, have tried to go thru thew installation process several time with no changes. any assistance would be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Variety Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-26
Last reply:
2018-01-27
Manfred Hampl (m-hampl) said : #1

What is the output of the command

apt-cache policy variety

on the system that has 0.6.6?

I assume that you have enabled a PPA (perhaps ppa:variety/daily) on that system, and not on the other ones (or different additional sources on these).

Dale Holtz (deholtz) said : #2

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

From: Manfred Hampl<mailto:<email address hidden>>
Sent: Wednesday, January 24, 2018 2:24 AM
To: <email address hidden><mailto:<email address hidden>>
Subject: Re: [Question #663473]: updating variety to latest version

Your question #663473 on Variety changed:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fanswers.launchpad.net%2Fvariety%2F%2Bquestion%2F663473&data=02%7C01%7C%7C12a53c2118fb41fe9d5d08d56303d7f0%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636523790506561339&sdata=9rVLLjv9a%2F9ZA5pmjimYECvGCWgsrEURbbqOmOzaaWw%3D&reserved=0

    Status: Open => Needs information

Manfred Hampl requested more information:
What is the output of the command

apt-cache policy variety

on the system that has 0.6.6?

I assume that you have enabled a PPA (perhaps ppa:variety/daily) on that
system, and not on the other ones (or different additional sources on
these).

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fanswers.launchpad.net%2Fvariety%2F%2Bquestion%2F663473&data=02%7C01%7C%7C12a53c2118fb41fe9d5d08d56303d7f0%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636523790506561339&sdata=9rVLLjv9a%2F9ZA5pmjimYECvGCWgsrEURbbqOmOzaaWw%3D&reserved=0

You received this question notification because you asked the question.

Dale Holtz (deholtz) said : #3

ale@ublackbox:~$ apt-cache policy variety
variety:
  Installed: 0.6.5-0~621~ubuntu16.04.1
  Candidate: 0.6.5-0~621~ubuntu16.04.1
  Version table:
 *** 0.6.5-0~621~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/variety/next/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/variety/next/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     0.6.5-0~600~201708221925~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial/main i386 Packages
     0.6.0-1ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-proposed/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-proposed/universe i386 Packages
     0.6.0-1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
dale@ublackbox:~$

About Variety indicates version 0.6.6

Manfred Hampl (m-hampl) said : #4

If you execute the same command on a machine that has variety version 0.6.4 or 0.6.2, what output do you get there?

Dale Holtz (deholtz) said : #5

dale@umonster:~$ apt-cache policy variety
variety:
  Installed: 0.6.5-0~600~201708221925~ubuntu16.04.1
  Candidate: 0.6.5-0~600~201708221925~ubuntu16.04.1
  Version table:
 *** 0.6.5-0~600~201708221925~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/peterlevi/ppa/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     0.6.0-1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
dale@umonster:~$

About Variety gives version 0.6.4
Running version0.6.4 on all other systems at this time.

Manfred Hampl (m-hampl) said : #6

On the first system you have ppa:peterlevi/ppa and ppa:variety/next activated, and on the second one only ppa:peterlevi/ppa

If you want to have the same version also on the second system, then you must define ppa:variety/next as repository source also on that system.

By the way, on the first system you have xenial-proposed activated, which is a setting that you should use only when you want to test a version of a package that has not yet been released for general use.

Can you help with this problem?

Provide an answer of your own, or ask Dale Holtz for more information if necessary.

To post a message you must log in.