Missing Variety panel indicator on LinuxMint 17.3 Cinnamon

Asked by var on 2016-01-23

Hello,

May be you could give me a hint.
What may cause variety indicator to completely disappear from panel?
I've tried re-installing and deleting ~./config/variety, no difference :(
It otherwise functions perfectly, however no indicator, no matter what I try (Light/Dark/Custom)

Question information

Language:
English Edit question
Status:
Solved
For:
Variety Edit question
Assignee:
No assignee Edit question
Solved by:
Peter Levi
Solved:
2016-01-24
Last query:
2016-01-24
Last reply:
2016-01-23
Best Peter Levi (peterlevi) said : #1

There have been no changes in Variety in this aspect. But the different desktop environment's support for app indicators is changing. I suppose some recent update in Cinnamon has broken this. Please read the "System tray" section here: http://linuxmint.com/rel_rosa_cinnamon_whatsnew.php, try the option they mention - "If you don’t like indicators, you can turn this off in “System Settings” -> “General” -> “Enable support for indicators”. This results in forcing all applications which use indicators to fallback to using status icons.". This might help.

var (variety2016) said : #2

Thank you for an excellent clue, I was able to find a root cause. Strangely enough, as it turned out alarm-clock-applet was to blame. Don't know how or why it managed to mess up my cinnamon panel, but after it was removed things went back to normal (I also had to delete ~/.config/dconf/<username> and let system re-create it)
Sorry for wasting your time and thanks for Variety.

var (variety2016) said : #3

Thanks Peter Levi, that solved my question.