Ubuntu 11.10

Asked by culky on 2011-12-02

Hello there,

Im trying to install on ubuntu 11.10 and its failing because i have gdl3 and its expecting gdl1. How best should i resolve this?

Here is the result of ./waf configure

Checking for program gcc or cc : /usr/bin/gcc
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for gcc : ok
Checking for program valac : /usr/bin/valac
Checking for gobject-2.0 : yes
Checking for gthread-2.0 : yes
Checking for program version valac >= 0.1.6 : ok 0.14.0
Checking for program msgfmt : /usr/bin/msgfmt
Checking for program intltool-merge : /usr/bin/intltool-merge
Checking for header locale.h : yes
Checking for program valadoc : not found
Checking for glib-2.0 >= 2.18.0 : yes
Checking for gio-2.0 >= 2.18.0 : yes
Checking for gobject-2.0 >= 2.18.0 : yes
Checking for gmodule-2.0 >= 2.18.0 : yes
Checking for gtk+-2.0 >= 2.18.0 : yes
Checking for libxml-2.0 >= 2.5.0 : yes
Checking for gtksourceview-2.0 >= 2.10.0 : yes
Checking for libvala-0.12 >= 0.12.0 : yes
Checking for gdl-1.0 >= 2.28 : Package gdl-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gdl-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gdl-1.0' found

Many thanks

Colin

Question information

Language:
English Edit question
Status:
Answered
For:
valide Edit question
Assignee:
No assignee Edit question
Last query:
2011-12-02
Last reply:
2011-12-05
augustulus (augustulus) said : #1

Hi ,
an dirty very derti way to compile is to instal libgdl1 and libgdl3 from older ubuntu versions manually.
(e.g. Download form : http://pkgs.org/ubuntu-11.04/ubuntu-universe-i386/libgdl-1-dev_2.30.1-1_i386.deb/download/)
Activate valac-12 and valac-12-dev; deinstall libgdl-3-dev.

then ./waf config .....
The compilation works well,

BUT : at the moment one error :
valide: error while loading shared libraries: libvalide-0.0.so.0: cannot open shared object file: No such file or directory

Well .... im working on this but
the dependencis should be fixed for Ubuntu LTS ....

Bye

Can you help with this problem?

Provide an answer of your own, or ask culky for more information if necessary.

To post a message you must log in.