valide needs libvala-0.12 on Ubuntu - where to get?

Asked by Christian González on 2011-01-11

I downloaded the bzr version of valide, and ./waf configure stops with

"Package libvala-0.12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libvala-0.12.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libvala-0.12' found"

But I did not find a possibility to install vala 0.12 on Ubuntu - could you help me hw to get it running here?
It must be possible somehow.
is there a ppa?

Question information

Language:
English Edit question
Status:
Solved
For:
valide Edit question
Assignee:
No assignee Edit question
Solved by:
Christian González
Solved:
2011-01-14
Last query:
2011-01-14
Last reply:
2011-01-11
Nicolas Joseph (gege2061) said : #1

Hello,

vala 0.11 is a beta release for vala 0.12. You can find the package in the PPA on the vala team: https://launchpad.net/~vala-team/+archive/ppa

Christian González (droetker) said : #2

Yes, but I still think there is something wrong - so maybe this is a bug?
1. the ppa does not contain a "libvala" package, only "vala", and "valide".
2. On my system there is "libvala-0.12-0" installed (libvala 0.11.3-0ubuntu1~mmvala1) - this *should* do it, but does not work - could it be that the configure script does not find the libvala-0.12-0 package?

Nicolas Joseph (gege2061) said : #3

1. On debian, I have several packages: libvala0, libvala-dev and valac
2. Yes libvala-0.12-0 is different to libvala-0.12

IMHO, it's a packaging bug.

Christian González (droetker) said : #4

Yes, seems so.
Do you use Debian sid? the libvala version in sid is 0.8.1, in experimental 0.10.1 - outdated.
Do you use the ppa with debian?
So should we convert this to a bug? Against? Val(a)ide?

Is it really a packaging bug? why does the wa configure script search for a "package"? shouldn't it search for a library to compile against? This would be more distro agnostic (and IMHO the right way)

Christian González (droetker) said : #5

Found the error.
libvala-0.12.0-dev (!) must be installed from the ppa.
BTW, this conflicts with libvala-0.10-0-dev from Ubuntu stock, so you have to uninstall that one.

Packages needed addidionally:
libvala-0.12.0-dev
libgdl-1-dev
libunique-dev

then "./waf configure" was successful.