How to tell upstart the number of ttys to start?

Asked by rkat on 2007-05-29

Running Ubuntu 7.04 (with upstart) as guest in a UML (user mode kernel) system, it gives me 6 terminals (6 xterms appear).
How can I reduce this (to 2)? (In system V, one commented the unwanted getty lines in inittab. But after some research, I still couldn't find out how to do this with upstart.)

Question information

Language:
English Edit question
Status:
Solved
For:
upstart Edit question
Assignee:
No assignee Edit question
Solved by:
Scott James Remnant (Canonical)
Solved:
2007-05-29
Last query:
2007-05-29
Last reply:
2007-05-29

Remove the /etc/event.d files you do not want, e.g. rm /etc/event.d/tty[3456] to remove 3 thru 6

rkat (rkat1) said : #2

Thanks for the fast reply!
Unfortunately, this is not enough (tried that before, sorry didn't mention it because I thought I was wrong in assuming it might be so easy).

The xterm windows 3-6 (uml virtual consoles) are still created. Missing the removed /etc/event.d/tty[3456], they do not have a login prompt, which is ok. So it seems to me there must be some else configuration that creates the 6 ttys. Just tested my uml kernel with Ubuntu 6.06 as uml guest and inittab tty disabling works. So at least it's not the kernel.

You'll always have at least 8 actual VTs, since that's the way the software is configured. (usplash uses VT8 and X uses VT7)

rkat (rkat1) said : #4

Thanks Scott James Remnant, that solved my question.

Kevin Shelton (kmshelton) said : #5

Why can deallocvt not be used here?

It could, but that's a question for usplash or X ... not Upstart

Tom Spink (tspink) said : #7

You can change the ACTIVE_CONSOLES setting in the /etc/default/console-setup file to activate specific VTs, if you also remove the appropriate tty startup files from /etc/event.d.