how execute init with --verbose option??

Asked by FBonG on 2010-09-08

Apparently there is next to no logging in upstart, but the man page holds out the promise that the --verbose option will bring relief, and log emits and process starts. That would be a good beginning- but how to do? Apparently I can't do it via telinit or in some upstart config file. I assume there's probably some obscure way in Ubuntu 10.04 to put an option to Grub2 which would be handed to the kernel and then peeled off to use when invoking /sbin/init (i.e. upstart).

To save me the hunt, does anyone know where to do this? If not I bet the easiest thing is to recompile init with the verbose option already on, but I'm hoping for a saner and easier solution.

Earlier question Q112224 probably would answer this- but no answers.

I saw an earlier question about whether upstart / init was started in the initrd.img files, and whether it was ordinarily run from there or from the regular mounted fs. The answer seemed to say "maybe" - too bad as I was quite interested in the answer.
Perhaps it is currently being done both ways by various distros, but if so that wasn't clear. That was Q85247.

Question information

Language:
English Edit question
Status:
Answered
For:
upstart Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-08
Last reply:
2010-09-13
Guy Taylor (thebiggerguy) said : #1

On start up hold shit to get the GRUB2, select the recovery option and press 'e', add '--verbose' to the end of the kernel line and finally press alt-x to run. This will not save in GRUB2 so don't worry about editing it to next reboot.

Barack Obama (dh9226542) said : #2

your problem is very crtical. I can not solved your problem. you need to visit here http://goo.gl/GHUVHc
 for solve your problem.

Can you help with this problem?

Provide an answer of your own, or ask FBonG for more information if necessary.

To post a message you must log in.