Problems with Update Manager

Asked by kiroro on 2008-03-17

Every time I run update manager, a pop-up window shows: 'Not all updates can be installed', 'Partial Upgrade suggested'. When I click 'Check' for new updates, an error message shows:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

So I tried 'sudo dpkg --configure -a', 'sudo apt-get update', but none of them worked. Now I have a long list of updates which I could not install.

Question information

Language:
English Edit question
Status:
Answered
For:
Software Updater Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #203069.

Revision history for this message
Vojtěch Trefný (vojtech.trefny) said :
#1

Thanks for report, but this not a bug in fact, so I'm converting this to question.

Revision history for this message
Vojtěch Trefný (vojtech.trefny) said :
#2

To solve your problem just open Terminal (Application→Accesories→Terminal) and type 'sudo dpkg --configure -a' (without quotation marks).

Can you help with this problem?

Provide an answer of your own, or ask kiroro for more information if necessary.

To post a message you must log in.