Unity loads (only in the 12.04 betas), but is completely unresponsive.

Asked by Michael Hazell on 2012-04-08

In Ubuntu 11.10, unity does not load. Compiz crashes, and other things crash. So I am on 10.04, and will stay on that if Unity is not fixed.

I have tried both beta 1 and beta 2 of 12.04, hoping that the issue is resolved. I only got half of it...

Unity loads, but is completely unresponsive. My laptop is the Toshiba M55-S139. My graphics card is ATI Radeon Xpress 200m.

Can someone help me? I have a driver package (.bin) for the graphics card, but it is specificly for RedHat and some other distro. If someone can develop a driver for Ubuntu using that package, then good. The driver package also supports other ATI cards.

How do I attach the file via Launchpad? If I can't then I'll attach it to my SkyDrive and paste a link.

I should also note that 10.04 with GNOME 2 loads just fine, without me having to mod it in any way.

Question information

Language:
English Edit question
Status:
Solved
For:
Unity Edit question
Assignee:
Nekhelesh Ramananthan Edit question
Solved by:
Nekhelesh Ramananthan
Solved:
2012-05-22
Last query:
2012-05-22
Last reply:
2012-05-21
Nekhelesh Ramananthan (nik90) said : #1

Can you please post your system specification like CPU speed, Memory etc. Probably your computer does not meet the minimum requirements for Unity.

Michael Hazell (techman-) said : #2

CPU: Intel Celeron M 1.6 GHz
GPU: ATI Radeon Xpress 200m, with only 32MB of graphics memory, with 128MB of VRAM, according to the kernel boot log.
Memory/RAM: 2 GB DDR3 533 RAM.
HDD (although it is not neccessary) 80 GB

If there is anything else that needs to be provided, let me know.

And can you please tell the Ubuntu developers to include the GNOME panel as a fallback, or give you the option to install that as the default and use that when booting off of a live CD.

Maybe make a special low GPU memory version of Unity?

Nekhelesh Ramananthan (nik90) said : #3

I think you have sufficient memory. I guess the issue is with your CPU and your GPU. Can you try using Unity-2D? It is almost similar to Unity 3D in terms of features and looks but is built differently. Unity 2-D might work on your system though I am not sure about this.

As for using Gnome Panel as a fallback, you can do it on your system. Once Unity greeter loads, press Alt+F2 to enter the virtual terminal and then install the gnome panel package. To return to the login screen press Alt+F7.

Hope this helps.

Michael Hazell (techman-) said : #4

How do I get to Unity 2D?

And can you tell Canonical to include GNOME 2 in this distro release? It's not that much space on the ISO.

Best Nekhelesh Ramananthan (nik90) said : #5

Gnome 2 Development has been stopped and has been removed from all distros. If you want a Gnome 2 like experience, you should try installing other desktop environments like XFCE or LXDE. You can install XFCE by typing sudo apt-get install xfce in the terminal.

As for Unity 2D, you can choose it at the login screen. To the right of your name, click the ubuntu logo. It will show you all the desktop environments currently installed on your system. Ubuntu 12.04 comes with Unity 3D and Unity 2D by default. So you can choose Unity 2D.

Michael Hazell (techman-) said : #6

Thanks Nekhelesh Ramananthan, that solved my question.