Start without unity --replace?

Asked by Pavlo Bohmat on 2012-03-08

Different versions of Unity for over a year does not start without unity --replace or compiz --replace... What should I do for a normal startup?
--
pricese + unity_5.4.0-0ubuntu2_amd64

Question information

Language:
English Edit question
Status:
Solved
For:
Unity Edit question
Assignee:
No assignee Edit question
Solved by:
Pavlo Bohmat
Solved:
2012-05-08
Last query:
2012-05-08
Last reply:
2012-03-24
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Pavlo Bohmat (bohm) said : #2

unity_5.6.0-0ubuntu4: FAIL

Nekhelesh Ramananthan (nik90) said : #3

Paul this is a bug you are facing on your end only. It would be helpful if you can submit a bug report providing all your system info using apport. You can do this by pressing Alt+F2 and then typing ubuntu-bug unity.

The developers can then have a look at this.

Anke Kernbach (an-ke) said : #4

I have that problem, too. But I doubt that this is a bug because unity starts normally logging in as a new created user on that machine.
Therefore I assume this to be a conflict of configurations (my home directory is older than compiz...). I tried to solve it by reconfiguring the compiz package and deleting the folders ~/.compiz-1, ~/.config/compiz-1, ~/.gconf/apps/compiz-1 and ~/.gconf/apps/compizconfig-1 but it did not work for me.
Probably there are further configuration files/folders which I have overlooked. Any hints?

Pavlo Bohmat (bohm) said : #5

yes, conflict of configurations in ~/.config/* <-- change and unity are not taught to deal with it!

backup/remove in terminal (without unity)
.cache
.compiz
.compiz-1
.gconf
.config
.gnome2
.gnome2_private

when the new session will create a new ~/.config/, copy only setting programs and the unity reconfigured