unity dash file search results are not shown in "home search lens"

Asked by tellapu on 2012-01-18

Since yesterday or two days ago, the main unity dash search does not show any files&folder results in the "home search lens" anymore. The applications, music, utilities (place with map, weather, ...) are shown without any problems. The files&folder-lens is present and when I switch to the files&folder-lens the recent files are shown, but it would not always search correctly.

I re-installed the lenses according to this post:
ubuntuforums.org/showthread.php?t=1853156
sudo apt-get install --reinstall unity unity-common unity-lens-applications unity-lens-files unity-lens-gwibber unity-lens-music unity-place-applications unity-place-files unity-scope-musicstores unity-services unity-2d unity-2d-launcher unity-2d-launcher unity-2d-panel unity-2d-places unity-2d-spread unity-asset-pool unity-greeter
And restarted the computer, but no success.

I also tried to stop, delete activity and restart zeitgeist:
askubuntu.com/questions/43097/unity-search-not-working

Thanks for fast help, because I use this feature multiple times an hour.

Question information

Language:
English Edit question
Status:
Solved
For:
Unity Edit question
Assignee:
No assignee Edit question
Solved by:
tellapu
Solved:
2012-01-20
Last query:
2012-01-20
Last reply:
tellapu (tellapu) said : #1

As nobody wants to help me ;-) , I installed synapse, still less bugier ;-). But it could not present me any files as well. I remembered I had a zeitgeist problem with synapse in the past. Fortunately I wrote the commands down and they worked:

To fix it open a terminal and run these commands:
zeitgeist-daemon --quit
cd ~/.local/share/zeitgeist/
rm -rvf fts.index/
zeitgeist-daemon

Hopefully this will help somebody else in the future as well.

Michal Predotka (mpredotka) said : #2

tellapu, thanks for the tip. I had the same problem with files search.

tellapu (tellapu) said : #3

Hi mmiicc! Great, you are welcome.

Anita (a-lewis) said : #4

tellapu, thanks! I've been searching on this for over a month and you gave me the fix!

tellapu (tellapu) said : #5

Hi Anita! Great this post helped you as well, the ubuntu community is
great. Anita sounds like a female user, wonderful! Take care, tellapu.

-----Original Message-----
From: Anita <email address hidden>
Reply-to: <email address hidden>
To: <email address hidden>
Subject: Re: [Question #185085]: unity dash file search results are not
shown in "home search lens"
Date: Tue, 20 Mar 2012 13:10:52 -0000

Your question #185085 on unity changed:
https://answers.launchpad.net/unity/+question/185085

Anita posted a new comment:
tellapu, thanks! I've been searching on this for over a month and you
gave me the fix!

Sorin Sbârnea (sorin-sbarnea) said : #6

Is the zeitgeist-daemon supposed not to return? In my case last line is "Commiting FTS index". I added a & at the end.

Still, even after doing this, I'm not able to find anything with Unity dash.

Note: my home directory is on NFS, but it worked initially but not anymore.

tellapu (tellapu) said : #7

Hi Sorin,
Sorry I don't know an answer to this question, but perhaps somebody
else ...

Sorin Sbârnea (sorin-sbarnea) said : #8

Never mind, I switched to kubuntu as Unity seems extremely unstable and resource eater.

tellapu (tellapu) said : #9

Have you tried Ubuntu 12.04? It is said it runs smoother and quicker,
even with Unity.