upgrade from 11.04 to 11.10 unity not working nvidia drivers

Asked by Orestis Gorgas on 2011-10-19

Hi!

I have upgraded from Ubuntu 11.04 to 11.10 in two computers which both have nvidia cards. In both of them Unity 3d is not working. Unity 2d (Ubuntu 2d) is working fine, Gnome 3 works fine as well. I had to install Gnome 3 after I saw I could not work with Unity 3d. One additional question is why the unity bar cannot be altered (the icons to become smaller) as we can in Unity 3d? I would stick to unity if I could do that, since I like Unity more that Gnome 3.

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Unity Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-22
Last reply:
2011-10-23
vignesh (vignesh-sarma) said : #1

Hi ,

I had the same problem.Its not actually a bug all you have to do is go to "additional Drivers" Install nvidia's Proprietary driver of your choice once again.I thing this is because when the OS upgrades it removes the old propitiatory drivers due to some incomparability with the new kernel.

Hi!

I have tried that but nothing changes. I tried it once again after you suggested it. I removed the nvidia-driver and installed it again and nothing happened. The same problem still exists. I think I should do a fresh install sometime.

vignesh (vignesh-sarma) said : #3

Hi,

I am sure about this one, but did try changing your shell from Unity 2D to Unity 3D when you login?

vignesh (vignesh-sarma) said : #4

I meant "I am not sure " not "I am sure" :D

sorry....

Again this time around I found that unity is far more buggier than the one in 11.04.But most of the ideas are awesome.May be it has to do with upgrading and installing anew might solve it.

This was the first time I upgraded rather than reinstall.

Can you help with this problem?

Provide an answer of your own, or ask Orestis Gorgas for more information if necessary.

To post a message you must log in.