Unity, screwup help!!!

Asked by Hidden_Cat on 2010-11-12

Hello, I have been trying out different version of ubuntu for a couple of years now. very interesting stuff.
Anyway, I installed ubuntu 10.10 x64 on my AMD Laptop. Works good for the most part.
I decided to monkey around and now I regret it. I really liked the new unity concept so I downloaded the unity packages and now when I boot my computer I can't do anything it's frozen. I have over 100 tabs of things open in Firefox and chrome, work related. I need to fix this rather than doing a clean install. I can't lose my work.

I also had Docky installed.

I ran ubuntu in safe mode, booted in no graphics
I ran a package repair thingy
and reset graphics to their default.
Please give me advice quickly because I'm real tired and after trying to recover I got it to boot somewhat but no top bar and I opened Firefox and chrome but I can't switch windows and everytime I click on it in the docklet it opens a few windows instead of switching it, please help hurry.

Question information

Language:
English Edit question
Status:
Answered
For:
Unity Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-12
Last reply:
2010-11-12

This question was originally filed as bug #674299.

Noel J. Bergman (noeljb) said : #1

Hidden_Cat, I can't help you with the Unity part, but I believe that you can salvage your firefox and chromium browser states by copying ~/.mozilla, ~/.cache/chromium and ~/.config/chromium.

Didier Roche (didrocks) said : #2

Well, that's not really a bug but a support question (the fact that unity doesn't start on some hardware is known and we will try to fix that for maverick). You should ask this kind of question on a forum. I'll turn this bug report as a question to continue the discussion.

Are you using autologin? I mean, do you have the list of user showing before unity is starting? If so, once you click on your user, please choose "ubuntu desktop edition" on the dropdown list.
If autologin is enabled, what you should do it it to start in failsafe mode and choose "get a terminal" (or a similar option, I don't remember the wording) and then edit /etc/gdm/custom.conf (with # nano /etc/gdm/custom.conf) and remove everything in it so that you have at the end:

[daemon]
DefaultSession=gnome

Then save the file and restart.

Didier Roche (didrocks) said : #3

So, once you are in the terminal, just do that:
echo "[daemon]\n" > /etc/gdm/custom.conf
reboot

and then, you should get after reboot the gdm screen and can login into the GNOME desktop.

Can you help with this problem?

Provide an answer of your own, or ask Hidden_Cat for more information if necessary.

To post a message you must log in.