no sound on icoming messages

Asked by Axel on 2018-09-23

unity mail 1.75 installed on linux mint 19 cinnamon. incoming mails are notified by the tilted bell. configured to play a sound at incoming mail, but sound file is not played. no error messages.

Question information

Language:
English Edit question
Status:
Solved
For:
Unity Mail Edit question
Assignee:
Robert Tari Edit question
Solved by:
Robert Tari
Solved:
2018-09-30
Last query:
2018-09-30
Last reply:
2018-09-24
Robert Tari (robert-tari) said : #1

I can't test 1.75, it's an ancient version, the current is 18.6.28. Nevertheless, Unity Mail has always used libcanberra to play notification sounds, so this part should in theory be the same. You can test it from the terminal like this:

canberra-gtk-play -f "/path/to/your/sound/file"

This works for me:

canberra-gtk-play -f "/usr/share/sounds/freedesktop/stereo/camera-shutter.oga"

Non-proprietary file formats (*.ogg, *.oga, *.wav) should play OK, I am not sure about the rest. If you run into problems with the command, file a bug against the "gnome-session-canberra" package.

Axel (dl1bgi) said : #2

Thanks for the quick answer. First I installed the current version of unity-mail, but there is still no sound. Running the test command in a terminal ends up in the message "Failed to play sound: Sound disabled".

Best Robert Tari (robert-tari) said : #3

I am sorry I cannot help you with this, but it seems to be a libcanberra issue (most likely some trivial setting). Try to search the Web for canberra-gtk-play Failed to play sound: Sound disabled - ultimately, you can post a question or file a bug on the gnome-session-canberra or libcanberra development page.

Axel (dl1bgi) said : #4

with dconf-tools it's possible to enable sound and select the desired sound file, but after reboot the setting reverts to the default setting (disabled). I'm confident, that Mr. Google knows the solution for that.
Thanks for your help!