application organization in launcher

Asked by Sam Gweon on 2012-01-23

I tweaked the original google-chrome.desktop and gnome-terminal.desktop and put them in the local folder, ~/.local/share/applications. I simply added some more short cut groups, so that they appear on right-clicking.

The google-chrome item on the launcher works great. However, with gnome-terminal, there is an issue.

If I run google-chrome using Alt-F2, or command line, then I see that the icon appears in the launcher uses my updated local .desktop file with all the bells and whistles.

However, with gnome-terminal, this is not true. In fact, to add the new gnome-terminal.desktop into the launcher, I had to use dconf-editor.

Now, when I run gnome-terminal the new launcher icon on the launcher, the application gets associated with that icon. However, if I run gnome-terminal using other means (e.g. "Open in Terminal" context menu for nautilus is something that I use quite often), then that terminal gets associated with a new icon that appears in the launcher.

Why this behavior? I like all gnome-terminal applications to be grouped under one icon. Any help?

Question information

Language:
English Edit question
Status:
Answered
For:
unity-2d Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-23
Last reply:
2012-02-02
Gerry Boland (gerboland) said : #1

Hi Sam
sorry I only saw this question now.

I have just roughly reproduced your problem. I suspect it is a bug with our handling of .desktop files. Just now I made a copy of gnome-terminal.desktop & customised it a bit. I have terminal kept in my launcher. Restarting launcher, I got two separate gnome-terminal tiles, and they did not interact properly with the application.

Would you be so kind as to report this please?
-Gerry

Gerry Boland (gerboland) said : #2

Thanks Sam!
-G

Can you help with this problem?

Provide an answer of your own, or ask Sam Gweon for more information if necessary.

To post a message you must log in.