Is there a single-workspace mode?

Asked by Stefan Wrobel on 2011-06-16

I set /apps/metacity/general/num_workspaces to 1 using gconf-editor but when I do <super>+s it still shows my workspace in the top left corner with the rest of the screen black. Shouldn't it just zoom out and show all of my running apps expose-style for that single workspace? I want to use <super>-s as an expose-style app switcher. I've never been a big workspaces fan, so I just want the one.

Question information

Tom De Caluwé (tom-de-caluwe) said : #1

The <super-s key combination is bound to the expo plugin in compiz. Having only 1 workspace doesn't change that. However, you can alter the key bindings with the compiz configuration tool. Install it by running:

sudo apt-get install compizconfig-settings-manager

You can find it by typing "ccsm" in the unity launcher. Now all you have to do is bind <super>-s to the scale plugin instead of the expo plugin. Pick the scale plugin in the overview and set the appropriate binding in the "Bindings" tab. I think you want to set the one with <shift>-<alt>-Up as a default. When you change it to <super>-s it wil show a warning about the expo plugin: just disable the expo key binding.

Stefan Wrobel (swrobel) said : #2

Compiz is not running. I'm using Unity 2D, which doesn't use compiz ... that's why I filed in Unity 2D.

Tom De Caluwé (tom-de-caluwe) said : #3

I'm sorry. I misread your question.

Tom De Caluwé (tom-de-caluwe) said : #4

Do <alt>-<tab> or <super>-w work?

Stefan Wrobel (swrobel) said : #5

<alt>-<tab> shows the normal application switcher where you can tab through the app icons, but not an expose-style view of workspaces like <super>-s. <super>-w does nothing

Ugo Riboni (uriboni) said : #6

Hi Stefan,
This feature is not implemented in unity-2d yet, as far as I know.
Currently you always get the entire workspace switcher even if you have only one desktop.

One quick workaround that may be implemented for this would be to have unity-2d workspace switcher "zoom" on the single workspace automatically, when there's only one workspace.
But as far as I know there's no work planned to do this.

Can you please report a bug on Unity-2d about this problem ?
https://answers.launchpad.net/unity-2d/+question/161736/+makebug

Can you help with this problem?

Provide an answer of your own, or ask Stefan Wrobel for more information if necessary.

To post a message you must log in.