Keeps booting into Parted Magic

Asked by tetris11 on 2009-10-14

I installed UnetBootin - PartedMagic onto my Windows7 partition, and it said that it needed to reboot in order to complete.
That is normal, because it usually uninstalls the next time I go into Windows.

However, when the computer rebooted it went straight into Parted Magic, WITHOUT any multiboot option. Upon exiting Parted Magic and rebooting, the same thing happens; it just goes straight into PartedMagic without any multiboot screen.

I've tried hitting F8 repeatedly and tried hitting Escape, but nothing. It just keeps booting into it. I'm pretty worried.
Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
tetris11
Solved:
2009-10-14
Last query:
2009-10-14
Last reply:
tetris11 (tetris11) said : #1

[Solved] I used SystemRescueCD to mount my windows boot partition and edit menu.lst, and changed timeout from 0 to 30, and deleted the 'hiddenmenu' line. (mount using ntfs-3g)
Logout -> reboot

This gave me time to see the grub menu at the boot screen, where I pressed 'e' and editted the script to:

root (hd0,0)
chainloader (hd0,0)/bootmgr

(That's for Vista/ Win7 , for Win Xp use:)

root (hd0,0)
chainloader (hd0,0)/ntldr