build error

Asked by Ali Gündüz on 2008-10-15

Hello,

I tried building a customized unetbootin but i kept getting the same error. So i tried building without any modification on a fresh source and still got the same error lines.

I am running gNewSense which is very close to Ubuntu except for non-free stuff. I downloaded the source with "bzr branch lp:unetbootin", make sure all dependencies are met and got the qt4-win and qt4-x11 pre-compiled packages from your repo.

The build script at the root directory works but only creates deb's for hard drive boot installation with defining the kernel and initrd. I want to build the complete unetbootin gui tool.

When I cd to /src/unetbootin of the source directory and try to ./build-eeeubuntu I get the error at http://pastebin.com/f1f2f6c88

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
Ali Gündüz
Solved:
2008-10-15
Last query:
2008-10-15
Last reply:
2008-10-15
Geza Kovacs (gezakovacs) said : #1

"#
WARNING: Failure to find: unetbootin.h
#
WARNING: Failure to find: unetbootin.cpp"

That doesn't sound good. It seems like for some reason the source files didn't get downloaded properly or are otherwise missing. Try re-checking out the branch from bzr, or use the latest source zip package at http://unetbootin.sourceforge.net/unetbootin-source-latest.zip

Try following the instructions at http://unetbootin.wiki.sourceforge.net/compile if you aren't already doing so.

Also, just run the "./build" script in src/unetbootin, not "./build-anythingelse"

Geza Kovacs (gezakovacs) said : #2

"g++ -c -m32 -pipe -Wall -W -O2 -DSTATICLINUX -DEEEUBUNTU -DQT_NO_DEBUG -I/usr/share/qt3/mkspecs/linux-g++-32 -I. -I. -I/home/ali/unetbootin/src/unetbootin/qt4-x11/include -o main.o main.cpp"

Oh wait a second, that's the problem. You're building it with Qt3, you need to be using Qt4. Install qt4-dev-tools and libqt4-dev, and hopefully "qmake --version" should output:

qmake --version
QMake version 2.01a
Using Qt version 4.4.1 in /usr/lib

If not, remove any qt3-related dev packages you may have on your system to ensure that the qt4 version gets used.

Ali Gündüz (gnufs) said : #3

Yes that was it! I thought it would something far more complicated :)

Thanks Geza!

Geza Kovacs (gezakovacs) said : #4

Ok, some comments on your custom version at http://www.aligunduz.org/FUSBi/

1. Your Linux version is linked against GLIBC 2.4, which isn't present on some older distributions (Debian Etch, in particular). Use the static qt4-x11 package at http://launchpad.net/unetbootin/trunk/trunk/+download/qt4-x11-glibc23.7z for building, to maximize compatibility.

2. Your executables are uncompressed, you'll save a lot of bandwidth by using upx --lzma to compress them

I've also additionally merged in your customizations as of revision 295, at http://bazaar.launchpad.net/~gezakovacs/unetbootin/devel-new/revision/295 (keeping custom versions as part of the upstream source tree tends to simplify collaboration and avoids the need to remerge changes for each revision), let me know if you need to apply additional patches or want commit access, or just maintain a custom bzr branch with your changes that I can sync mine to.