Can't load Puppy

Asked by goodwik on 2008-09-26

Trying to set up dual-boot with Win98 / Puppy on old Sony Vaio laptop with 128MB RAM and non-working CD drive. Downloaded Puppy files using Unetbootin, rebooted and selected Unetbootin from menu. Then heard accesses trying on the CD drive apparently trying to find files which were on the hard drive. What do I do now ?

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
Geza Kovacs
Solved:
2008-10-06
Last query:
2008-10-06
Last reply:
2008-10-06
Geza Kovacs (gezakovacs) said : #1

Win9x unfortunately has some bugs that prevent 7-zip from working from within UNetbootin; thus the puppy iso file was likely not extracted properly (and thus you have it searching the CD drive for the files that weren't extracted to the hard drive). Thus, any of the options that install via iso files won't work; however the ones that install directly via the initrd and kernel should theoretically work (unfortunately I don't have access to win9x, so I haven't tested this in a while). I believe any of the "-Netinstall" options should work (Ubuntu 8.04-Netinstall, Fedora 9-Netinstall, etc), so you can use those to get a lightweight environment (I believe any distro with fluxbox should run fine on that laptop).

However, if you really want Puppy, I believe it will work if you download 7-zip and the puppy linux iso seperately, and extract the contents of the puppy iso file directly into the root of your C:\ drive, preserving the directory structure, then just reboot and select the UNetbootin option again, it should work then. Again, I don't have access to win9x, so I can't test any of this.

goodwik (goodwik) said : #2

Sorry I wasn't specific enough. What I was trying to do was to to use Unetbootin to load Puppy onto a USB flash drive so that I could later use a Wakepup floppy (the laptop's floppy drive still works) to boot the laptop. When I mentioned the hard drive it was because I believe that's where files are stored until you reboot after the initial download of the Puppy iso and the USB drive gets loaded. Is that right ? When I rebooted, it sounded like the computer was looking for something on the CD drive which doesn't work.

Best Geza Kovacs (gezakovacs) said : #3

Oh, so you're trying to make a bootable USB flash drive? In that case, the main issue is that syslinux doesn't work when run form win9x, I'm not aware of any workaround for this, so run UNetbootin on another computer (one that's running Windows 2000/XP/Vista, or Linux) to make the flash drive.

goodwik (goodwik) said : #4

Thanks Geza Kovacs, that solved my question.