How can I install OpenGeeeU on an USB drive to have it bootable?

Asked by TheDarkMaster on 2008-09-21

Hallo, I downloaded the Linux version, gave it my OpenGeeeU distro's iso to eat, choosen USB installation and pointed to my USB card. Before doing this, I formatted my USB card to Fat32 using Gparted. The process took no more than 5 minutes (is this normal) and then the program told me that the card was ready. Pluggin the card into my eeepc and booting it resulted in a grub error (17). How can it be? My OpenGEU is an Ubuntu derivate but I suppose I didn't have to specify Ubuntu anywhere since I was going to install to USB drive.

Also, another thing that concerns me is that I tried to use an install in that exact way the ubuntu eee version from their website and the error is the same. My usb drive is 1GB large, I don't think this is the problem. What I am doing wrong in your opinion? I run on an Ubuntu Hardy system right now and OpenGeeeU is based on Hardy too.

Question information

Language:
English Edit question
Status:
Answered
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-21
Last reply:
2008-10-05
Geza Kovacs (gezakovacs) said : #1

Grub Error 17 sounds like a problem, since syslinux, not GRUB, is the bootloader that's used by UNetbootin. Seems like there's some residual junk on that USB drive which is messing up the boot process. Rather than formatting your drive using GParted, try this after unmounting your USB drive. Note that it will wipe out anything on your USB drive, this basically turns your USB drive into "superfloppy" format without an MBR. I assume your USB drive device is /dev/sdc, replace it with whatever it actually is, but do NOT include any of the trailing partition numbers (eg NOT /dev/sdc1).

sudo mkfs.vfat -I /dev/sdc

Then once it's done formatting, eject the USB drive, put it back in, hopefully it mounts properly, then run UNetbootin again and target it towards the USB drive, see if it works then. Also if that doesn't work, and you have access to Windows, try reformatting the USB drive using the Windows format utility, then run UNetbootin from Windows.

Can you help with this problem?

Provide an answer of your own, or ask TheDarkMaster for more information if necessary.

To post a message you must log in.