p7zip installed but not found by UNetbootin

Asked by jay on 2013-12-07

(Someone has already posted a message with this title but it was wrongly marked as "solved".)

Unetbootin uses p7zip and I believe is expecting to use the command "7z". However, in Linux the p7zip command is operated through the command "7zr", which is a mismatch. So I get a message saying I do not have p7zip when in fact I do.

In my /usr/bin folder I have 7zr, so I can extract .7z files.

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
jay
Solved:
2013-12-08
Last query:
2013-12-08
Last reply:
2013-12-07
Geza Kovacs (gezakovacs) said : #1

nope, 7zr isn't the full p7zip. 7z is. 7zr can't extract iso files

jay (azi) said : #2

I've solved the problem now. When compiling the p7zip software for Linux you have several options. In addition to using
make 7zr
you will also need to do
make 7z

The final files are placed in the 'bin' folder, which includes all the necessary 7z files.

(If you have 7zr in /usr/bin you don't need to do "make 7zr'.)