Ubuntu 13.04 with correct md5: "invalid or corrupt kernel image"

Asked by DiagonalArg on 2013-06-04

Hi all. I'm trying to install Ubuntu 13.04 desktop, 64 bit on a USB (with 1MB persistent). I've done it before, but it's now it's not working. When I make the USB and try to boot it (ThinkPad T60p), I get the dreaded "invalid or corrupt kernel image". The md5 of the .iso is fine, and when I "test the disk for defects" instead of trying to boot ubuntu, I get "Check finished: no errors found".

Anyone have any idea what's up??

Question information

Language:
English Edit question
Status:
Open
For:
UNetbootin Edit question
Assignee:
Geza Kovacs Edit question
Last query:
2013-06-09
Last reply:
2013-06-07
DiagonalArg (diagonalarg) said : #1

I have now tried on two different USB sticks with the same results. The command that is failing ("Default") is:

/ubnkern initrd=/ubninit file=/cdrom/preseed/ubuntu.seed boot=casper quite splash -- presistent

On the other hand, "Try Ubuntu without installing" leads to a terminal login (whose default credentials I don't know):

/casper/vmlinuz.efi initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper quite splash -- presistent

DiagonalArg (diagonalarg) said : #2

Removing "persistent" from the second command allows Ubuntu to boot properly. Removing it from the first has no effect - it still reports "invalid or corrupt kernel image".

How do I get persistence to work properly?

Geza Kovacs (gezakovacs) said : #3

Thanks for reporting! I've fixed this issue in the latest release (584) which you can find downloads for on the website.

DiagonalArg (diagonalarg) said : #4

@Geza - thanks, but I'm still having trouble. Now, both Default and "Try Ubuntu without installing" produce a splash screen, but then I end up at a terminal login:

Ubuntu 13.04 localhost.localdomain tty1
locaholst login:

I tried ubuntu/"" and ubuntu/ubuntu to login, but neither work.

DiagonalArg (diagonalarg) said : #5

... and by the way, if I do C-Alt-F7 at the login prompt, I'm just led to a blank screen.

DiagonalArg (diagonalarg) said : #6

... in both cases, getting rid of "persistent" boots properly. So I'm still stuck with the issue of getting persistence to work.

(And while I am not doing this now, I would ultimately like to have persistence in a separate partition.)

If there is anything I can do to provide more information, I'd be happy to.

Can you help with this problem?

Provide an answer of your own, or ask DiagonalArg for more information if necessary.

To post a message you must log in.