unetbootin broke my usb

Asked by nick verheijen on 2013-01-12

I used unetbootin to try to make my usb stick into a bootable linux disc. But I ran the program and now my usb stick doesn't get recognized anymore as an usb stick (or as anything in general, nothing happens when I put it in the computer) in any computer (i tried several).

It seems like your program broke my usb stick, and I'm not very happy about that since it was quite pricey..

Is there a way to fix this problem? Or should i just throw it in the dumpster?

Question information

Language:
English Edit question
Status:
Answered
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-12
Last reply:
2013-07-09
Szymon Nieznański (isamu715) said : #1

Have you tried reformatting the drive with GParted?

No but I will. Don't know how to reformat a drive that does not get recognized at all by the computer though.

Szymon Nieznański (isamu715) said : #3

It's possible that it is actually recognized but there are no valid partitions so it doesn't get displayed in the sidebar or in file manager. If that's the case the drive should still be visible from GParted and reformatting should solve the problem.

Javier Barroso (javibarroso) said : #4

Using unetbootin from debian sid, I had the same problem

I cannot recover my usb dongle:

# dmesg | grep -v SRC
[465681.311120] usb 1-4: USB disconnect, device number 7
[465684.184050] usb 1-4: new high-speed USB device number 8 using ehci_hcd
[465684.316409] usb 1-4: New USB device found, idVendor=1307, idProduct=0163
[465684.316413] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[465684.316765] scsi9 : usb-storage 1-4:1.0
[465685.316830] scsi 9:0:0:0: Direct-Access USBest USB2FlashStorage 0.00 PQ: 0 ANSI: 2
[465685.317345] sd 9:0:0:0: Attached scsi generic sg3 type 0
[465685.318687] sd 9:0:0:0: [sdc] Attached SCSI removable disk
# LANG=C fdisk -l /dev/sdc
# LANG=C fdisk /dev/sdc
fdisk: unable to open /dev/sdc: No medium found

Before using unetbootin the device worked fine :(

I know it comes without any warranty

gparted doesn't recognize the dongle

I think I will have to buy one

Thank you

t-man (mathijs-lankhaar-3) said : #5

Guys, do you still have those sticks? Still broken? I might have a solution.
A while ago i was inspired by U3 flash drive and i tried to convert my regular flash into a improvised U3-like device. I used a tool to "burn" iso files as a CDFS partition to my flash drive, tried linux images, all worked fine. But that was on a Sandisk Cruzer (non-U3 ofc.), a branded flash drive. Nowadays I use my 32GB MaxFlash pendrive (30GB actually), tried that tool few days ago. After the tool is "ready", it keeps eating cpu, have to replug my flash drive before I can use it again. No single partition shows up and after formatting the size of my flashdrive is decremented with the size I've set for the CDFS partition. However, I can fix it with that same tool.
In UFdisk I try to make an "autorun" but set the size to zero, and don't select any ISO to load.
Now I've to reformat it and my flash drive 30GB again.
This instructable has the download links (http://www.instructables.com/id/Mod-to-the-ultimate-USB-U3/step3/using-UFDisk/).
Read carefully, it depends what kind of flashdrive you have, I've never used the other tool.
Good Luck

Victoria (me-victoria) said : #6

This worked for me on windows, in the prompt window enter the following:

$diskpart
$list disk

you'll see the disks that the system recognizes, one should be the hard drive and the other the usb flash drive. In my case disk 1 was the usb flash drive.

$select disk 1
$clean

$create partition primary

$exit

I hope you can use it!

Can you help with this problem?

Provide an answer of your own, or ask nick verheijen for more information if necessary.

To post a message you must log in.